Unable to publish a team create game with unpublished changes to packages that apparently don't exist

  • Describe the bug. Describe what is happening when the bug occurs. Describe what you would normally expect to occur.

Working on a large map with various models that are repeated throughout, I created a bunch of packages for this purpose.

Each time the team create session or myself tries to publish the game, I am given this error: - Error: Cannot publish place while there are packages with unpublished changes. However, there is no orange bar at the top of the screen pointing me towards the unpublished packages, and also there is no package in the explorer that has not been updated.

  • How often does the bug happen (Everytime/sometimes/rarely)? What are the steps that reproduce the bug? Please list them in very high detail. Provide simple example places that exhibit the bug and provide description of what you believe should be the behavior.

Every time I edit my game, the orange bar directs me to the unpublished packages, I click “Get Latest Version” on each one and the orange bar goes away, but the game still cannot be saved.

  • Where does the bug happen (www, gametest, etc) Is it level-specific? Is it game specific? Please post a link to the place that exhibits the issue.
  • Would a screenshot or video help describe it to someone? If so, post one.

No orange notification, can’t save error in output.

  • For graphics bugs, it is sometimes helpful to know your system specs, especially graphics card.

Not sure this is necessary but i5-7600k and Radeon rx580.

  • When did the bug start happening? If we can tie it to a specific release that helps us figure out what we broke.

In the last month or so.

  • Anything else that you would want to know about the bug if it were your job to find and fix it.

It’s worth noting that another player can join the team create and they will be directed to the “unpublished” packages, but upon updating them the same issue occurs, no way to save and no package that needs to be updated.

Also, if this does get fixed, it would be nice if team create would prompt you when trying to leave if it is unable to save, if the output wasn’t open I could’ve clicked X and instantly lost that much work.

6 Likes

Thank you for showing us this issue. We are currently looking into it and will keep you updated.

6 Likes

I’m still facing this issue. Is there any estimation as to when it will be fixed?

4 Likes

It’s important to add to this bug report that this feature always happens with the same package(s); cloning the package to another place will always reproduce the issue, and this happens regardless of whether the user created the package or not.

This is severe as it can easily go unnoticed when leaving a Team Create and will lead to data loss, as the TC will not save on exit.

30 Likes

I also experienced this bug recently but it happened through toggling team create so I could do an online test for my dev version of the place.

My packages appeared out of date and even after deleted (directly deleting PackageLink or not) it is impossible to publish the game.

In general packages preventing place publishing is extremely dangerous behaviour as shown by this bug. I believe packages should be published with the place even if out of date and should show that they need an update upon reloading to prevent data loss.

Is there any output in the console, and if so could you post it here?

I believe that my issue is slightly different than yours (all of my packages had orange update icons next to them)

I received an error only after deleting the PackageLinks in which case I received the same error you saw in the console.
Otherwise I received the message asking me to publish changes to the packages and was unable to update them (I don’t remember if there was an error when I tried this or not, but I remember that they remained out of date no matter what I tried).

1 Like

I figured out how to replicate this bug: the issue seems to be when Humanoids are a descendant of a package. Trying to publish the game while a humanoid is a descendant of a package gives me the error Error: Cannot save place to Roblox while there are packages with unpublished changes.:
image

Process of how I discovered how to replicate the bug

I thoroughly tested to make sure it’s Humanoids that is causing this issue. I have multiple packages in my place and at first I thought all the packages were causing the issue. So I removed them all and I was able to publish. However I had a feeling it was something specific causing this, so I deleted each package one by one and I found out it was a package that had models, which were children of module scripts, of which are a child of the main package (a module script), and in those models there were Humanoids. I tried removing the models and I was able to publish.

I thought the models being a child of a module script was somehow the issue, so I made a new Folder package and placed the models in there. The bug occurred again, and I was stumped. What else could be causing the issue? I tried removing the Humanoids and voila! I could publish my place. I copy pasted humanoids into packages and tried to publish, with the bug occurring every time.

Thankfully, I don’t need Humanoids in my packages- I was going to delete them through scripts anyway. However, I did lose 15 - 20 mins of my work (which is 15 - 20 mins after I placed models with humanoids in a package) because my game did not save its progress, and the AutoScriptRecovery only recovered 5 mins of work.

I hope this helps in fixing the bug. I apologise if it’s known, this is the only post I could find about this. I did find a somewhat related post but it seems too specific:

1 Like

Hi, we are actively fixing the bug. Thanks for reporting!

Any update on when this will be fixed? It’s a very annoying issue.

1 Like

I’m actively working on it. It’s a complicated issue. We will release the fix in stages. And first stage will be released later this week. Thank you!

Update:
This issue has been addressed as of Oct 9. We will release some feature changes to allow save place with modified package inside next week. Stay tuned~

Update 2:
You are now able to save a place with modified package inside for teamcreate place and non-teamcreate place. We will make an official announcement later this week.

3 Likes