Unable to publish or overwrite certain games

Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: N/A
Date Last Experienced: 2021-02-06 00:02:00 (+02:00)

Reproduction Steps:
All games are under group: 1038305

  • Publishing failure-
  1. Open place of id: 5995947407
    1.5 (Optional) edit something
  2. Publish by going to File → Publish to Roblox
  3. Studio tries to publish for a long (5+ minutes) period of time
  4. Failed to save in output
  • Overwriting failure -
  1. Open place of id: 5341377190
  2. File → Publish To Roblox To… → Select group → Select game of id: 5995947407
  3. Select starter place and publish
  4. Wait for it to try and process
  5. Failed to publish

Expected Behavior:
When trying this with my personal group I can open any place and publish without any issues and near-instantly too.

Actual Behavior:
As soon as I click publish studio stutters then Publish button greys out for a few minutes

then in the output, I get " Dev0mar || Fishing Frontier publish failed."
microprofile-20210206-004401.html (790.6 KB)



This has been happening to me too for a week now. I am not able to publish my games due to which I have to save them everytime on my PC. I tried uploading on all my groups even on my user but it shows Publish Failed error.

It has been happening to me since 2020 when uploading models, assets, places except for animations stopped working as :
my game failed to save / publish

Some features doesn’t work sometime that im stuck at “publish is failed”
and I couldnt fix it (even with VPN!), I had to ask friend to publish update for months.
Till I buy new pc or managed to reinstall windows I’m stuck at very impactful network bug.

1 Like

I have this error, I cannot publish nor overwrite games either.

Experiencing the exact same error as well

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

Please note that filling a bug report does not guarantee that it will be fixed once triaged.


Bumping this because it’s starting to happen to me, and nothing I can find on Google, YouTube or the DevForum can help me.

What i’m trying to do is override a place inside of a game I made, and then it just spends like 10 minutes in the publishing screen, then it just shows me this:

This is very annoying, I tried to override a place and since that wasn’t working i tried making a new place. Still doesn’t work.

Edit: I tried restarting Studio, then restarting my pc, then re-installing Studio.
My internet is honestly very good right now considering everything works perfectly fine in Roblox Studio and anything I do online, with the only problem being the publish fail.

You’ve missed the most critical piece of info: the link to the game.

it’s happened to me today, i overwriting place to another place and it’s take so long, and the overwrited place doesn’t change i believe there are people who are experiencing this problem as well, but too few.

1 Like

Been happening to me for weeks, except I hit overwrite and nothing happens. No error or anything in the output. Only thing that happens is that the overwrite button turns grey.

This sucks because I’d like to have different versions of the game that have different server sizes, voice chat only, etc. This is extremely annoying


Can we get a look into this ASAP? I feel like this is a somewhat critical bug because this completely prevents developers affected from publishing what they have made. In my case, I cant publish games that were saved to file unless I upload them to a completely new place. When I try to publish to Roblox by overwriting an existing game I get stuck on this screen below no matter how long I wait. It is extremely tedious to work around this issue.

Note: This is only from File → Roblox overwriting


I’m having the same problem. Even though I try to insert a brick into the game and make small changes, it still won’t publish… I even saved the game on my PC, and overwriting doesn’t work either, as shown on the screenshot.

We found out what caused this for my game, and I’ll write about it in case it helps anyone else.
The reason why our game wouldn’t publish was because there was an excessive amount of textures and/or meshes in the game.

Our only solution to this was to save the map as a file, remove the map from the game, overwrite the game into its desired place, and then open up the overwritten game and import the map file.

Edit: It should also be noted that for some reason, this only happens when OVERWRITING a game. Publishing as a new game works fine.

Hi everyone!

To have this issue better looked at, I would recommend for those that are still encountering this problem to file a new bug report with as much information as possible! Check this thread before you do!

Also, thank you for the possible workaround, @1nicopatty!