Unable to upload some images to Roblox without failing or mangled results


#22

They do automatically compress them in-game for low end devices but that is only after they are uploaded. Meaning that yes it does help with performance but it doesnt help with load times which is an issue with our game.

It could be my fault but I cant find a reason why. I can only think that roblox isnt reading the image correctly when I upload it. But thanks for your help.


#23

I’m also having issues uploading decals to my account, however I’m not having the issues when uploading to a group. If you have a group you can upload it to that for now until Roblox gets a fix.

Photo I’m using

Error I got
ERror


#24

I had the same issue. One of my images was being dense and wouldnt upload. Tried everything until saving it as a bmp let me upload it for some reason. I’d try that.


#25

i also think its on his end not on roblox end.


#26

I don’t think all of us having this problem is a coincidence. Wouldn’t make sense.


#27

For some reason I can’t upload this image it gives me an error.

Image:

Error:
image

Sorry for lack of contrast the dark theme doesn’t support it, but I know the theme is not the problem.

Anyways I uploaded the “O” no problem (it’s in a separate image) but yea any ideas on how to fix this or anything?

No problems opening the image with other programs, I exported from Adobe Illustrator as an asset and Windows Images and all other programs can read & edit it fine.

I also tried importing the decal image via Studio but it didn’t work.

Update:
Any images I upload with transparency are showing up opaque now too. I uploaded a logo for my development group, and here is the output.

Input:

Output:

Not entirely sure what’s going on but hopefully this will get figured out quickly.

Thanks,
-big


#28

There are some serious problems going on with the image uploading. I am getting the following errors when uploading images. I tried uploading via the Game Explorer, as well as via the Importer.

1. PNG Alpha Transparency Is Not Showing
When I upload PNG images with alpha transparency, then the transparency is replaced by a solid black background.

2. Upload failed. Make sure what you are uploading is an image.
Some of my images will not upload at all.


#29

UPDATE:
I am not certain, but these problems may be related to image optimization such as the images output by Optimizilla, TinyPNG, etc.

1. Working - Photoshop PNGs
Save a PNG image in Photoshop, and upload it to Roblox.

2. Not Working - Other PNGs
Uploading PNG images output from Optimizilla or TinyPNG.

Not sure why #2 is not working all of a sudden, as these images used to upload just fine to Roblox within the last week or so.

The problems that I am seeing for #2 are the alpha transparency being replaced by a solid color, and sometimes the image will not upload with error: Upload failed. Make sure what you are uploading is an image.

Hypothesis:
Something has changed at Roblox to prevent some PNG formats from uploading correctly.


#30

Are you all still experiencing this issue when you upload the images from studio?


#31

Our team has used that in the past but when we transferred the build over to the actual game, the textures imported using that method didnt transfer over to the actual game. While I haven’t tried the method, im to traumatized from the last experience to use it.


#32

As of an hour ago, yes these problems occurred when I upload from Studio via the Game Explorer, or Uploader. I also tried uploading via the website with the same problem. Photoshop created PNGs work fine, but other PNGs do not.


#33

That’s intersting since I just opened my images from Illustrator in Photoshop, and when I exported again they seem to have worked now. Strange :thinking: You would think the 2 programs use the same PNG export method, but I suppose they do not.


#34

My guess it has something to do with PNG compression, or optimization. This was not an issue about a week ago, but something must have recently changed on the Roblox end in which certain PNG files do not upload properly, or lose their transparency.


#35

I will give you some temporary solutions that I discovered:

  • Did you upload a black and white image, but it turns out completely black? Instead of uploading it in PNG format, upload it to JPG
  • Did you upload a PNG image but it does not come out with a transparent background? Add a translucent layer back and fix
  • Do you erase the image after uploading it a second time? Change the contrast a little

#36

Just wondering if the Roblox Staff has seen this thread, and if a fix is in the works? Not being able to upload optimized PNG images is a big problem.


#37

Upon further research, I believe that 8-bit PNGs are the problem. In the recent past, 8-bit PNGS uploaded fine, but now they lose their transparency, and on some occasions they cannot be uploaded at all.

Repro:
Two PNG images are shown below. One is a 32-bit PNG saved directly from Photoshop. The other is the exact same image, but saved as an 8-bit PNG (with transparency).

image-png-32bit

image-png-8bit

I uploaded both images in Studio, and placed them in ImageLabels. You can see the results below. The 32-bit PNG shows the transparency as expected (top image), but the 8-bit PNG shows a solid color instead of the expected transparency (bottom image).


#38

Whenever I upload an image to studio that doesn’t fill up the whole canvas, it gets a black background.

For example, I was uploading this image. image
and it doesn’t have a background, apart from the plus itself. In roblox studio, I was getting this: image
I tried restarting studio, helped once but then it started messing up again, and restarting didn’t fix it anymore.

I haven’t been doing UIs for a few days, but last time I did it was working just fine. I haven’t changed any settings or anything since then.


#39

I uploaded this image:
BuildIcon

This is what I see when looking at the decal on the website and in studio:
image

I tried doing it through studio first. Then I tried through the website. Happened both times. Never experienced this until today.

Here is a link to the decal:

Thanks.


#40

I can’t reproduce this when I download your hammer image and upload it to the site. Could you give more details?

If you change a pixel and reupload, is the problem resolved?

See also: Please Read Before Posting: Steps to Report a Bug


#41

Yes, I tried uploading after changing a pixel. It did the same thing. I don’t know what other details I can give. All I did was upload the image, like normal.