Unable to upload some images to Roblox without failing or mangled results

#62

I see, but how come when I uploaded the same file again it suddenly decided to work?

0 Likes

#63

Will uploaded Decals be fixed later or we’ll have to upload them again once the problem is solved?

0 Likes

#64

I think these will need to be uploaded again. The files we’ve seen exhibiting this issue appear to be broken during upload.

0 Likes

#65

Looking at the two underlying images you uploaded @RuizuKun_Dev, the correctly rendered one is 32bit color depth, the black-background one is 8bit. If you’re on a PC, you can see the bit depth of a PNG by opening the properties window for the file (right-click -> Properties) from explorer and going to the details tab.
image

0 Likes

#66

I see, I must have mistaken it for the same file.

Please let us know when the issue is resolved.

I would wait until then before uploading any decal to Roblox.

0 Likes

#67

ah thank you

0 Likes

#68

Ah, nice to see this is being worked on. I had simple single colour red bat wings with a transparent background saving with a black background today.
Checked the image properties and it is 8 bit.
I’ll give it a few days for you guys to fix then check back here.

0 Likes

#69

Jpg is unaffected and upload fine.

Here are some example images that got inverted/outlined/line-patterned when uploaded. I tried uploading newly created pngs, editing pngs, and old pngs downloaded from the internet a year ago.

image
image

Assets in screenshot:

Symptoms include:

  • Scanlines over image
  • Flipping of color between black/white
  • Cropping of images (half goes missing)
  • Transparent pixels become solid

Edit:
Adding color helps. Must be an issue with roblox’s new compressor change


image

3 Likes

#70

still broke

1 Like

#71

Has anyone tried this recently? Has it been fixed?

1 Like

#72

This unfortunately still occurs, I encountered this about ten minutes ago as I had forgotten about this bug.

1 Like

#73

Image uploading still doesn’t appear to work in terms of badges, unfortunately.

Tempting_Fate2

This is a 24-bit .png I’ve attempted to upload, and it uploads fine.

The same image, when converted to 8-bit depth, is not recognized as an image by Roblox as demonstrated.

Both 24 and 32-bit depth seem to work out fine, but uploading either as a badge image doesn’t work, throwing up this error:

Until then, I’ve decided to hold off on badge uploads. Image/decal uploads work fine, however.

update: 4 hours later, and even more attempts to get the badge uploaded later (including compression)… still nothing. :confused: I’m convinced that image uploading for badges is completely broken for me, or something is very wrong with my computer.



(Yes, the above image also failed to upload. 24-bit PNG.)

4 Likes

split this topic #74

5 posts were merged into an existing topic: Off-topic

Read below.

1 Like

#78

Seems like a parallel issue to this – consider creating a new bug report if badge uploading fails with literally all images (all png depth levels, jpeg, etc).

3 Likes

Unable to create badges
#79

Now I’m experiencing this problem. I made an image in Paint.net from scratch, saved it as a PNG, and got mangled results.

I uploaded it from studio, and oddly enough, it looked fine in the game image section but not actually in game. Resaving it as a JPEG fixed the problem. I can attach a repro if needed.

1 Like

#80

@TobotRobot Would you be able to give an update as to how Roblox is progressing on a fix? Thank you.

0 Likes

#81

I think it got fixed cause im not having this problem anymore since yesterday.

0 Likes

#82

Hey, I believe we shipped a change on March 12 to fix 8-bit PNGs having mangled transparency (or worse).

We have been unable to reproduce the issue where images fail to upload with the message: “Upload failed. Make sure what you’re uploading is an image.”, but I’m hoping these two issues are related and that fixing one fixes the other.

1 Like

#83

I had no trouble, just in-case I’ll provide a link: https://www.roblox.com/library/2982761109/testformistertitanic44

0 Likes

#84

I am unable to upload 32 bit, 24 bit and 8 bit pngs. Which is making it very frustrating due to being unable to upload any decals to roblox.
Update
I tried uploading some of the exact same images to one of my alt accounts and roblox allowed their upload, so I assume it’s an issue to do with the Beta program.
Further Update
It isn’t just the beta, I was uploading on an alt and then after 3 uploads the problem continued. Large issue this as it means I can’t change my Group Logo or upload a single decal.

1 Like