Unable to upload unions "Exceeded Limit"

Any time I try to publish a place with a union in it, I get this error


Can you send me a place that fails to upload? This is an odd error to be getting.

It’s any place at all, not just a single place

1 Like

I would make a repro anyway so that it’s easier to test for them.


pls.rbxl (17.7 KB)

1 Like

Interesting. I’m not seeing any issues when I open and publish that place. I’ve also tried creating some parts, unioning them, and then publishing. Still no errors. Do you have a stable network connection?


Yeah, as far as I know

1 Like

I’m bumping this because the issue is back and is affecting all my places with Unions in. Same OS, same system, and I’ve also noticed that the toolbox fails to load saying “No models available” My internet connection is very fast, so I don’t think it’s from my end.


For the past few months (beginning somewhere around July-September 2019), this error has terrorized me and I’ve finally had it with it.

This isn’t an error that happens all the time; only sometimes. This error occurs when I attempt (sometimes) to publish a game. Usually when this happens, I can publish the game again as if nothing happened. There’s no reason I can see for it to happen nor are there any indicators it may happen. However, from what I can gather, it’s only happening when I’m working with relatively complex unions. Other than that, it’s just random.

There’s not really any reproduction steps I have either except repeatedly publishing the place and waiting for the error to pop up. If I had to give it a probability of it happening, it would be a 10-20% chance of this error occurring.

There are three specific models I have that seem to cause this error. If an engineer would like to dissect it, you’re gonna have allow me to DM you the place file solely because it’s not something I can publicly post here.

System Specs

  • Windows 10 Pro
  • Intel Core i5-8300H
  • 12 GB RAM
  • NVIDIA GeForce 1050
  • 256 GB SSD, 1 TB HDD, 2 TB External
  • 32 GB Intel Optane

I have this issue now.

When I click publish, it gives the error, and when I click public place as, I get this long wall of warnings.
Another side note is I’m also getting this error when trying to update my plugin.

I literally have ONE union in my game, which consists only of 5 parts.
Also, it doesn’t show any games here


Getting the same problem. Whenever I try publishing my local rbxlx file to Roblox, I get this in the output:

Studio ends up hanging for a solid 4 minutes before unfreezing after this.


I believe this happens only to specific OSes and only specific devices. Can’t reproduce(Unions over 50 parts)

1 Like

Just a minor update : The issue is occuring to me with binary (rbxl) files as well.


I have had the same issue multiple times. Sometimes recreating the whole union works but most of the time I just send the file to a friend and ask them to upload it. Buggy RBXStudio is my guess.

1 Like

Seems like this issue has stricken again, bumping. This seems like a pretty bad problem that isn’t given enough attention, hopefully someone can find a fix.


I can’t upload my gun animation because of this.


I also have this issue, and have isolated it to some unions I created in an offline file. Separating and re-unioning did not appear to fix the issue. Removing the unions from the model allows the place to be published, and re-adding them one at a time does not work, as they all, individually, prevent publishing for some reason. A solution would be welcome.


This just started happening with me while map making and happened when I went to upload an animation.

1 Like

I just started getting the same issue with the game I am trying to publish and unlike other times when it did let me publish on 2nd try this time it doesn’t let me publish at all. Also the thing is someone gave their game to me and when it was published to their game it worked fine but for some reason it doesn’t want to work for me

1 Like

I am also experiencing this issue.

I can not upload my experience to Roblox because of it. I suppose I would have to start my work all over again, which is suboptimal (and given, that this arbitrary error may re-surface again after building).