Unanchored parts not moving/falling

I have unanchored parts in my game which are frozen in the air, when running the game the parts are still stuck and cannot be moved. I have checked to see if something is anchoring them but they are still unanchored when the game is being played, are there any solutions to this or is this a bug?

1 Like

Are they a lot of parts? Sometimes this happens if there are a lot of unanchored parts in close proximity to each other, they will eventually fall though.

If they are anchored on the server, but unanchored on the client, the physics engine could have an issue with it. Could this be the case with you?

I’m on a baseplate with 4 parts in

The are unanchored on both,

Are they massless, and what is the workspace gravity?

They aren’t massless and the gravity is 196.2 under workspace

Do they react to physics if you touch them? Or, in run mode?

When running they don’t fall, no matter how much I touch or move them they still act as if they are anchored.

I would normally say this might be a plugin interfering… but it happens with me as well, rarely though. I hardly use any plugins, so i wouldn’t think it was that… have you tried to restart/re-install studio?

What happens if you try approaching the part?

Just tried to reinstall yet the same problem occurs.

It still acts as if it’s anchored

Even when being very close to the part?

I can stand on it and push it without it moving

you’ll have to provide a test file for people to truly debug this

anchoredparts.rbxl (40.6 KB)
Heres an example of it happening, though its happening in all files I open

the part dropped to the floor for me, without any involvement.

It very well could be a plugin or your own computer, have you tried playing it on a public server (not studio?) if it works on public server its likely a plugin doing it.

I would’ve thought a plugin couldn’t change it as while the game is running the part appears unanchored on the client and server, i’ll play a public server to see what happens.

Must be an issue with roblox studio as in a public server the block falls perfectly fine