UnionOperation invisible even though the transparency is set to 0?

  • What are you attempting to achieve?
    I am attempting to use UnionOperations to make a door way.
  • What is the issue?
    The UnionOperation is invisible even though the Transparency is set to 0.

  • What solutions have you tried so far?
    I have tried:
    Deleting the UnionOperation and adding it back (Ctrl-Z)
    Seperating the UnionOperation (It literally deletes the UnionOperation with no parts found)
    Relaunching Roblox Studio

This issue is happening within every UnionOperation in this game.


I’ve had that bug with some of my unions too, and I do think it is a Roblox bug. Even though it wasn’t appearing in Studio for me, it was still appearing in game, so I saved the game and re-opened it and it was fine.

A union this morning that I made was invisible too.

As unions are stored by Roblox, any internet issues that arise during the creation of the union will likely impact its final form; i.e., it may be invisible or appear incorrectly.

Some of these Union bugs happen. Save, close, and reload Studio. That usually fixes it.

However, for your use case, I wouldn’t use a Union anyways. You can replicate this (and not have to worry about weird collisions) with seven Parts.


It appears that your union got corrupted. This tends to happen to most people every now and then.
Since your attempts to fix it didn’t work there’s really nothing that can fix this issue. You’ll have to spend a few moments recreating it. As infuriating as this may be, especially in cases with more complex geometry, that’s just how it be.

Tips to try and minimize the risk:

  • After recreating the shape you can create a copy and put it in the ServerStorage as a backup before you try the UnionOperation again. – I usually just create dupelicates in workspace until I know it’s complete
  • Double check the parts axis and size. Unions tend to work best with parts all on the same axis. i.e parts that are all flat from say the front and back. – This isn’t really an issue unless you’re doing a lot of operations with a lot of parts whilst not using any incremental settings.
  • And the most 100% safe way…Create a mesh. Unions, at the end of the day, are basically simplified mesh creators. That’s why they can sometimes be unreliable. It’s turning your selected parts into an editable geometry with scripts. It’s perfect for quick operations to get nice shapes, but there’s no actual control over how the polygons are modified.

Corrupted union. No way to save or recover your union. You’ll have to remake it, but try and save copies of your parts until you’ve verified it’s what you wanted.


Unions are a sin, just use regular parts. Keep in mind that unioning everything doesn’t increase performance.

1 Like

Unions are a pain. Sometimes you can’t get away from them. Once I got used to them it was not too frustrating Except Brick Cutter Plugin doesn’t work on unions

1 Like