Unions disappearing when separating

I’ve been working on a business class seat recently and I have had issues with the union disappearing when separating to edit the height of the bricks.

Then when I try to union that part with another, it shows up with this message:

Is this a mistake that I’m doing? Is it a studio error?
I’ve read that unions can get corrupt and I really don’t want my build to disappear as I have worked really hard on it for the past hour.

Your video isn’t loading for me, it comes up with an error. Btw, I believe I have seen that error when I tried to union a union, but it might be a different code.

Hi. This has been discussed many times before. Roblox has had many bugs with solid modeling for many years (so no, you aren’t doing anything wrong). Some users suggested different ways to prevent this from happening, take a look at these threads for example:

PeZsmistic made a guide a few months ago on recovering corrupted unions, this might help you:

1 Like

Here is how I fix mine! Hope this helps.

Thank you!! This is by far the easiest method that I’ve seen!

1 Like