Unions Failing to Load

Okay, so I’ve been working on a cat model for a game via unions/negates. Everything has been working fine, up until I saved, and left the game; ready to go to sleep.

After returning on the next morning, the unions have went invisible.

I’ve tried testing it in play mode, viewing developer console, and trying many solutions - such as deleting the ROBLOX cache, yet I’m having no success.

The only information I have obtained is;

-The unions are not invisible
-The collision works fine in play mode, yet you still cannot see the union

-I cannot separate the unions, as it does not allow me (it gives no popups or anything, I just click it, and it doesn’t do anything)
-When I try to negate, I get this error message:
-People in TC also cannot see the unions
-I have tried to tick on this:

This is what the head looked like before the incident:

Please help! I would love to finish this lovely cat model and put it into a game. ; (



Sounds like your model was corrupted unfortunately. You could try disabling CSGv2 and try to separate again.
Also consider posting your model here: CSG Failures

In general, it’s a good idea to avoid unioning everything together as you’re working, and even after you’re done. Work in pieces and save those pieces somewhere, because CSG can often go very wrong.


Very true. I have had unions go invisible in the past and it can be annoying. I once made a door and the union went invisible and I had to rebuild the door. It was a hassle.


Thank you for the reply! Yeah, it’s pretty annoying how it did that. I’ll keep your advice in-mind, and try to recover a previous version maybe. :frowning:

1 Like

Try copy-pasting this union in a different place, uploading that place, and testing if it’s visible online.

Wow that is an impressive model of a Cat.

Good job!

This often happens to me, since I like to work with unions.

When it happens, all it really takes is me closing and re-opening studio. After that the problem is usually solved. You might want to try doing this.

Another thing I suggest doing is to try and possibly union a random brick with it. This could possibly have the union reload, and make it visible.

If that doesn’t work, I suggest doing what others said.

  • Trying to put it into a new game
  • Saving a local copy, and trying to see if it’s in that
  • Go back on an old save

The cat looks amazing by the way. I hope one of these solutions work in a PAWS-itive way.