Unions not appearing?

Hey Developers,

So I opened up studio, and all my unions were gone. They are still there, but I cant see them. I’ve tried separating the unions and re-unioning them - but seemed to just delete them. Here is a screenshot:

  • Blue is the roof union.
  • Purple is the back wall union.
  • Red is the floor on top of the wall.

The unions are all set to visible, i’ve tried restarting studio- Cant seem to find out why my unions are doing this. I’d assume it is just a glitch, but its everytime I open this one world/game.

Thank you for reading.

1 Like

It seems that your unions got corrupted. As far as I am aware, there is no way to fix this besides remaking them from scratch. This is a bug that has been happening for a long time. Apparently Roblox doesn’t care because they never made any attempt at fixing it


Please use the Search button up top. There are many other threads such as yours already.


Nah, maybe if we make enough threads Roblox will finally decide to fix it


It is an intended feature, but we won’t explain the reasoning of this because of the numerous other posts with the same question and answers.

1 Like

This same problem happens to me a lot. I just avoid using unions in general because of how easily they are corrupted.

1 Like

Even the other threads do not help with the issue, I agree with @Elocore. Roblox does not care about this issue even if players still have this problem from 2 years from now.


This is a pretty common issue that people are having. Consider searching before posting similar threads like this have been posted before and answered. I wouldn’t say that Roblox does not care it’ll probably get fixed soon or later, as for the OP I recommend rebuilding the unions because that’s the only way to do so.

That isn’t a solution that’ll get Roblox to fix this issue any faster there will just be repeated topics asking the same question or having the same problem over and over again do not do this search in case your question isn’t a duplicate an answer to your problem might be on existing threads. CC @Elocore

1 Like