Universe assets broken in studio test server/client

Universe assets are broken in studio test server/client, this likely started occurring in the latest client update.

Repro steps:

  1. Create a universe linked asset (decal) through the game explorer.
  2. Use the asset through its universe asset id (example: rbxgameasset://Images/test).
  3. Start studio test server/client. The decal will load on the server studio instance, but not in the client studio instance. This message is printed out in the error console:

Image “https://assetgame.roblox.com/asset?universeId=0&assetName=…&skipSigningScripts=1” failed to load in “…”: Request failed.

I noticed that the universeid here is 0, this likely is not correct. Were there changes made to this recently?


This bug can be reproduced from this (minimal) file:

test.rbxl (14.0 KB)

Upload this place file to create the universe, then create an Image asset named “test” (all lowercase).

Also reported here:

I can confirm the same error. Other users have also posted the same bug.

Currently, any game that I run via Test: Start will not show any gui images.