[Update] Changes to Asset Privacy for Audio

I don’t understand why I am unable to grant my group experience the ability to use my profile’s sounds. I have specifically granted my universes the ability to use the audio, yet the audio discovery plugin still shows the red X, for many other sounds as well. Please advise.

1 Like

dude awesome so many things are broken!
you cant even play funky friday now lol


That’s a visual bug or an unintended feature, I’m sure that only shows audios that last more than 6 seconds.

Same thing for the “grant permissions to all” pop-up when publishing, it’s such a confusion when trying to find IDs to change.

Literally 9 audios out of 10 I find there are uploaded by me and are granted permission, they also play in game.

I’m not so sure, it might just be a fluke right now. Music files from my inventory are working on a friends’ game, even though I don’t have edit access to the place. I also didn’t authorize their use.

It still won’t load my song even when the marketplace went back up. Let me paly my song roblxo pls

Seems my audio does not work on my own game, even though I already gave it permission.

1 Like

That probably confirms it then, the deafening hasn’t happened yet and it’s just Roblox’s marketplace screwing up.

1 Like

I deafening has already happened. It’s just everything else broke at the same time. Actually I think its gradually happening

1 Like

Wow! Just like I said, it did happen according to the image below. Told you IDs would be useless now!

1 Like

How else do I load my music in then? I can’t do it locally or it won’t play for other people.

I’ll wait until it’s properly integrated before making changes, just to ensure nothing is messing up.

1 Like

If anyone has scripts that play audio I recommend putting this before the audio

If sound.IsLoaded then

you never know when your audio is just gonna not work for whatever reason
Also, maybe add an else with a placeholder song just for extras


It would’ve been nice if all games up till now, would auto-accept any (VALID) sounds to preserve their functionality, and any future edits require new audio to be allowed.

It kinda sucks that all these old games that won’t get updates have basically been ruined by this update and the complete disregard for this platforms history.

There are alot of creators who aren’t around anymore either from leaving the platform, or could’ve passed on and their works are now all ruined.


what are you on about lol they literally said audio <6s wouldn’t be privated but they privated them.


Seems to work for me now.

The problem is the very confusing “grant permission” and crossed IDs in the plugin.

I am asked to grant permission for audios shorter than 6 seconds that are public for everyone by default, which then floods the output with failure errors.

I managed it with some annoyance on my side, but what about people who have a bigger project with a lot of audios they don’t own mixed with a lot of audios they DO own?

This has to be due to some weird catalog/privacy bug, it seems that many audios, even ones under the 6 seconds are just no longer usable, even if they are owned by Roblox or are rightfully being used in a game made by the audio creator, where they SHOULD be able to work. They aren’t deleted on the Roblox website but rather don’t have the play icon to play the audio preview anymore, and in studio they are shown as “0 seconds long” which is the main indication that something is broken/bugged here. I really hope this is just a bug that will be fixed soon, as it was previously indicated on the plugin that a lot of these audios would continue to work after today.

(Above are audios published by my friend, we tried to play them in his game and it would not work at all)

1 Like

This is indeed a bug with a few shorter sounds that’s being worked on, the cutoff is 6 seconds.


You can’t due to some kind of bug. The staff are working on it now and should be fixed soon.

1 Like

Is the update actually out yet? I’ve had audios that theoretically shouldn’t work still work.


We are currently investigating an issue with the Marketplace. Assets may appear unavailable and audio may no longer play as expected.

1 Like