Uploading decals breaks and corrupts them. // (What should I do?)

I was recently making an game, and came up to an point where I wanted to make an little animation about clicking the mouse, nothing important in this context…


The main thing in this whole problem is the first normal mouse picture.

Now, when I try to upload it to Roblox, I can, everything works normally, Roblox allows me to upload it, It uploads everything, and then, when I try to use it in studio, nothing, nothing appears, and when I look at the site, this is what comes out.
image ?!?!?!?!?! What is this, here look I am not joking.

And then, I changed like a pixel of the image, saved the same picture again, since I had my picture editor open with the original picture, and uploaded it again, trying to maybe fix it, maybe problem at the servers, who knows?


image
Not the thing I uploaded…
Then, copied over the image, made another file, pasted the image in the editing software, and uploaded it again…

image
Nope…

So, long story short, I can’t upload any decal, it just corrupts them, It also doesn’t allow me to use them in-game, now, I don’t know where the error persists, is it at Roblox servers, is it in the file, which I don’t think it is, is it something else, I don’t know, but also, notice how I can upload the file on the Dev Forum, normally… What is happening here, I don’t know, but I am still posting this here…

  • Also, I don’t know If this is how usually it is, but since like the start of this year, decal page previews turned into this demonic weird corrupted previews, these are not the colors of the images I uploaded… I just ignored it before, but since I am making this post, here, I don’t know if it is supposed to be like this, but still…

(Also, I really don’t know what else to say about this, do I need to give something else, like PC specs or something, since this is only an picture and an upload service, I really don’t know what can cause it…)

9 Likes

I am having the same issue too. When I upload a texture of a model i made, it looks fine in Roblox Studio. But when i look at the image itself on Roblox, its all a garbled mess.

4 Likes

I’m having the same issue here with how you specified it.
The odd demonic and inverted (usually in pink or green) decals have been going on for a while now but I never noticed this scan-line problem until now.

Looks fine (the usual inaccurate color) when viewed on Develop page but it’s not right when anywhere else.
image

image

2 Likes

@TRUSTIVENO1GaminG, @Evercyan

This whole topic is about 30 days old, and in the meantime I have found an sort of a fix that works for me (Note: That still doesn’t mean that roblox should ignore, and not fix the problem.), I don’t know if you have the problem where the decal won’t show up in-game and in studio, but that’s what I will be talking about and if you ever encounter that problem you can try this trick, I have found an alternative way to use these “broken” decals without re-uploading them.

image

Okay so, the ImageLabels are different, and you can clearly see that, the number 1 label is using the orignal Decal ID or Asset ID, whatever you want to call it… And the second one is using the Decal Image ID. And you can clearly see that something is wrong with the original Decal ID, when I input the Decal ID, it gives an output as: Image “https://assetdelivery.roblox.com/(LinkHere)” failed to load in “(Image Location)”: Request Failed

1st Image Label uses:


2nd Image Label uses:

So long story short, just get the Image ID of that Decal, don’t know how that fixes it, but it does the job somehow.

If you don't know how to get the Image ID.

To get the Image ID, I really don’t know what chrome extention allows this option, I think its Roblox+…

Go to broken Decal, then click Linked Items, and there it is, the original Image. Just click it, and copy its ID, and it should work.

2 Likes

Sorry for bumping but this problem hasn’t been solved. And it’s even worse as now my decal shows a random game screenshot(and no I don’t have anything to do with that game):

2 Likes

I think it would be much easier to fix if you post the image information as well, for example with https://exifinfo.org
Example picture:
https://i.imgur.com/kABUEwQ.jpg

Personally I never had issues with corrupted decals but I’m always ensuring my images are progressive (noninterlaced) and have sRGB (Adobe RGB should be fine too) colour profile. You can also try stripping any ICC, IPTC, EXIF, XMP (etc.) metadata and upload again.