ViewModel flinging me off the map?

This is my first post on DevForum, believe it or not!
Anyways, I was just making Fake Arms (ViewModel) for a FPS game.
When I look down and jump, I get flinged?
I’m 50% sure that it is happening because of the display arms

Can somebody please explain to me how that is happening?

1 Like

Do your arms have CanCollide on? Do they have a humanoid in?

Wouldn’t you want the can collide for the arms off, so they don’t collide?

(and yes it has a humanoid)

The Humanoid will force parts of your viewmodel to be CanCollide on, you need to move all the parts in your viewmodel to a different collision group that doesn’t collide with other CollisionGroups

So, are you saying that I have to move the viewmodel to another collision group.
And that I have to seperate it from the default collision group?

Unless you need the Humanoid, use an AnimationController for animations. Humanoids do some weird stuff lol

(That’s what I know atleast)

Also, I tried that and it still does the same. :confused:

Animations are not a problem for me… for now. I just don’t know why the Display Arms are flinging me off the map?

Its just that (im pretty sure) humanoids try to stand up so its flinging you. Try it without the humanoid and see if it works maybe?

But, I need the humanoid for the animations to work? I wouldn’t be able to use the animations I made without a humanoid?

You can actually animate objects with an AnimationController. It works just like the humanoid for animations like :LoadAnimation() and :Play(), but doesn’t have features from the humanoid like jumping and climbing and walking and stuff so that could possibly fix your problem.

Can you show me an example of how to use AnimationControllers?

You could read the documentation page @devinkid1 sent, but here it goes. You wanna set the animation preferably with a variable, local loadedAnim = animControlReference:LoadAnimation(animationReference), and to play, loadedAnim:Play(), simple as that.

1 Like

Its exactly like using animations with Humanoids. To load an animation with a variable you use local testanim = animationcontroller:LoadAnimation(directory) and use testanim:Play() to play, like any other animation.

Edit: I did not see that @zamd157 said pretty much the exact same thing as me oops

Okay, I guess. But, how do I stop the humanoid from trying to make me stand? Should I enable Sit or PerformStand?

I don’t really know. Try making it sit and see if that works. Else you should just use animationcontrollers.

ok i just tried it and it didn’t work

1 Like

But, how will animationcontrollers help it from not flinging me out the map?

And, also, how would you edit the animation in the animation controller?

It doesn’t have the states that humanoids have that would try to make you stand up, etc

Rigs and animations work the exact same in animation controllers. If you want to make an animation, just click on your viewmodel rig like any other in the animation editor. To load an animation with a variable, you do:

local Animation = controllerRef:LoadAnimation(animationRef)

And to play the animation you do: