Viewportframe rendering black textures on mobile

Some viewportframes are rendering models as black instead of applying the texture. I initially thought this might be because our game is texture heavy, but you can see the same textures being rendered on the model in the workspace in the 2nd image:



Device: iPhone X
Does not reproduce on PC

Edit:
Forgot to include, the game this happens in is World // Zero

4 Likes

What game is it? How can I reproduce?

The game seems to be World // Zero.

1 Like

What is the system version of your iPhone? I can’t reproduce on my device.

iOS 13.1.3
iPhone X
Note: this is only happening for MeshParts with textures, the other viewport frames are using materials such as Plastic / Metal.

Did it start happening yesterday? Reproduce 100%? What materials are those MeshParts?

I’m not sure when it started happening - I only ported this to mobile as of late last week.

The materials are Fabric. (To achieve minimal glossiness)

That’s probably the same bug with Lighting issue with materials set to fabric

1 Like

My game also makes the player avatars the fabric texture to reduce glossiness and mobile users have had this same bug that makes characters completely black for the last two or so days. Here is an example.

1 Like

This also happens for the 3D preview of everything on the catalog of the mobile app:

OS: Android 7.1.1

1 Like

Reverted some changes. It should be fine now.

1 Like

3 posts were merged out – please do not respond to bug reports if you have nothing significant to add / please stay on-topic and do not respond to spam

Forgive me if you have a release schedule for this fix that I am unaware of, but it seems that this glitch is still happening to mobile users. I have also been told that lowering your graphics setting to two or below fixes the glitch in game. I will provide two screenshots below to demonstrate this, both of which were taken today at 8:00 PM.

Graphics above three (Silhouettes)

Graphics below three

Are you using fabric? What device, system, app version and game is it? If it still exist after restart, that must be a different issue. I tried some devices but can’t reproduce.

As I said previously, yes, I am using fabric. There has been a very bad “glossy characters” problem for quite some time now, and switching player avatars to the fabric texture fixed it, at least until recently.

As for the silhouette glitch turning avatars into shadows, it did still exist after a restart, but since you posted your reply to me, it seems to have been fixed.