VR in Roblox - Can't turn off?

So I’m trying to work on some stuff in VR, but I’m not sure how to turn it off. I’ve unplugged it from my computer but Roblox still thinks I’m doing VR when I open a game. Any suggestions?

8 Likes

I had this problem before. You need to quit SteamVR, it’s dodgy like that. It can’t be a tray process either, so use task manager

Even if I quit SteamVR, it just opens up again whenever I open a game again.

1 Like

That’s really strange! Perhaps try going through all the Vive & SteamVR processes. i.e. SteamVR Server, VivePort, or anything with Steam, Vive or HTC in its name. That normally helps when I have issues w/ SteamVR.

Shutting off all Steam/Vive related services doesn’t resolve the issue. This is a SteamVR bug, and there is no known user-fix – ROBLOX tried implementing a patch themselves, but it appears it was broken by a SteamVR update.

I had to shutdown my PC to get it to turn off

I’m having the same problem with my Vive.

2 Likes

What I do to fix this is simply unplug the linkbox USB from my computer. Works like a charm :slight_smile:

1 Like

This was not actually possible when this thread was made. SteamVR would activate regardless of if your linkbox was plugged in or not.

You can thank @zeuxcg for fixing it.

2 Likes

Bless the #ZeuxGod

3 Likes

That should really be a trending tag by now

1 Like

ikr

1 Like

Easy fix, unplug the little box that connects your HTC Vive to your PC, it looks like this image
Just in-case here’s where I got the image: [Removed because website became malicious]

2 Likes

When this bug was still going on, unplugging the box did nothing. You had to restart your computer

2 Likes

such time could/would rather be spent on playing ROBLOX without interruption!

2 Likes

Good news, everyone! There will soon (couple of weeks) be an option in the settings menu to toggle VR. You’ll still have to reopen Roblox, but I think we can all agree that it beats unplugging anything.

8 Likes

Thank you, our VR overlord!

While you’re here, any updates on adding developer option to remove the default VR interface?

1 Like

We’ve also done a lot of work on making it as minimally intrusive as possible. No more UI automatically showing (other than the backpack should your game use tools and you haven’t disabled the CoreGuiType), it’s all behind the radial menu in this new update.

You will also be able to use game.StarterGui:SetCore(“UseLaserPointerVR”, false) to turn off the lasers on your hands, so you can make games that have their own input mechanisms. But keep in mind that you get quite a bit for free when you leave this on, so I don’t recommend it unless you’re really feeling like doing a lot of work.

4 Likes

Wait…Since when did we have lasers?

Is that an occulus-only feature? I guess so, hah.

Regardless, thanks! I’ve been waiting for this for an age to get properly good VR in ROBLOX.

:ok_hand:

1 Like

So I’ve a bit of a different problem, I want to run my virtual desktop and play roblox at the same time, but it refuses to launch. I assume it has something to do with the VR service running already.