VR only works if headset is whitelisted and physically connected via USB

Roblox will only launch in VR mode when a headset, which has to be physically connected to the computer via USB, is in a manually updated whitelist.

I am trying to play Roblox in VR mode on an Oculus Quest using the software Virtual Desktop. The VD software allows SteamVR to detect my headset + controllers and stream VR games over wifi from my computer. Here we see that SteamVR correctly detects my headset and controllers. The only thing physically connected to my computer is the xbox controller.

image

Despite SteamVR running and working with my devices, Roblox will not run in VR mode when the game launches. And after hours of combing the forum I think I have discovered why.
Due to a SteamVR headset detection bug @zeuxcg had to implement a workaround so that SteamVR does not automatically launch every time you open Studio. You can read about it below.

His workaround works by checking if you have a whitelisted headset connected via USB. If it finds a device it will launch SteamVR and then you can play in VR. This workaround was decent when only two headsets (Rift+Vive) accounted for 95% market dominance. But now, over 3 years later, zeuxcg has to manually add new headsets to a whitelist every time someone complains about Roblox not working with their headset.

This completely defeats the purpose of using SteamVR for VR support because you will still have to manually do something for every imaginable headset that ever exists. The next problem with this workaround is that is only works with headsets physically connected to the computer via USB. Even if the Oculus Quest is in zuexcg’s whitelist, Roblox will not run in VR mode because I am using Virtual Desktop and don’t need to physically connect my headset to my PC.

This is the bug zeuxcg reported three years ago, does this bug still exist? The status says closed? If this bug really still exists in OpenVR all these years later we should at least have a better workaround. At least an advanced setting which allows us to ignore the whitelist and force Roblox into VR.

Windows 10 Home 1909
SteamVR 1.12.5
Virtual Desktop Streamer 1.13.6
Oculus Quest (Via Virtual Desktop)
SteamVR System Report

30 Likes

I’ve actually had the opposite effect for my headset. I use the Oculus Quest via Oculus Link, and have only used it on Roblox once.

However, even after I wasn’t using it, both studio and the engine put the game into “vr-mode.”

Roblox seems to be ignorant of VR issues, so I wouldn’t expect this to get fixed soon :confused:

4 Likes

Note: this only applies for headsets that use SteamVR. If you’re using an Oculus headset (via Quest Link or Rift/Rift S) or a WMR headset, this won’t apply.

1 Like

I have the exact same issue, and asked the developer of VD if there was anything that could be done on his side.
He confirmed that Roblox only checks for a USB connection.

This is a hindrance for me as I don’t have much space to store my connected Oculus Quest and test with it while working at my machine. It would be much easier and more convenient to test and play via Virtual Desktop.

Also, the fact that the bug where you have to disconnect the USB just to stop Roblox from using the headset (which doesn’t always work) is ridiculous for VR developers.

@zeuxcg when will these issues be sorted?

3 Likes

I also asked the developer of VD before making this bug report and suggested some functionality which can spoof a connected USB device. But he doesn’t think it is possible.

1 Like

I’m another user with no other option for VR other than an Oculus Quest and Virtual Desktop, I haven’t got any way of doing Oculus Link as I have no PC that works well enough with Oculus Link alone, I have to use a virtual PC using a service called Shadow and that works well enough for me in most cases.

I personally really wonder why Roblox only allows whitelisted headsets. I get that using both VD and an Oculus Quest (let alone Shadow) is a very circumstantial thing, and in the fact that there is a whitelist at all, I can see why we’d be overlooked/ruled out, but personally I don’t see why this whitelist is in place whatsoever. I feel if SteamVR is open and detects any sort of headset, Roblox should boot into VR mode.

It’s really saddening for me personally because I’ve been itching to create Roblox VR experiences ever since I got my headset… :frowning:

4 Likes

The original post explains why there is a whitelist. It’s a short sighed workaround which apparently doesn’t always work.

1 Like

I see now. It’s still a pretty big bummer for those without certain headsets.

Thanks for the report! We’ve filed this internally and we’ll follow up here when we have an update for you.

6 Likes

Aweeesommee! Just bought the app for the quest specifically for Roblox VR testing. Glad to hear a solution is coming up!

1 Like

Thanks for posting this bug. This issue has been put in the backlog of things to fix and the relevant teams will look at this issue.

13 Likes

Can we get an update on this? How far has this bug moved to the front of the backlog for example?

6 Likes

I really hope this bug can get fixed, I personally use Shadow and my Oculus Quest 2 and I’m saddened that this doesn’t work. I’ve scoured the internet for any way to do this, but nothing works. Hopefully Roblox fixes the issue soon.

10 Likes

Shadow released a beta for there new vr thing. I’ll try it in a bit, hope it works.

Edit: Nope it just launches steam vr.

3 Likes

Still no update almost 6 months later?

5 Likes

I am waiting for the engineers to give me some info. As soon as they do i will pass it on.

5 Likes

I have an update. As per the engineers, This issue may get fixed as part of a big bug fix roll out. If it doesn’t then it probably will not be fixed this year. Hopefully it will be fixed. Not sure when the fix will be rolled out but when it is i will pass on the info.

6 Likes

Please also fix the delay where headset controllers have a ~0.5 second delay for the buttons.

2 Likes

Can you please just suggest this to be hotfixed until their hypothetical VR revamp / bugfixes come out? If you can pass the post below this one directly to any engineer who can work on this problem then everyone who plays Roblox VR games will be eternally grateful.

To recap what this bug is: The current intended behaviour is that Roblox automatically launches into VR mode if you have a headset connected (to SteamVR). But a certain SteamVR headset detection bug meant that Roblox would always try to launch into VR. So this workaround was made. This workaround basically checks if certain USB headsets are connected to the computer. So now the headset has to be whitelisted and physically connected to the computer via USB for Roblox to consider launching in VR mode.

Apparently this workaround doesn’t work anyway since people are saying that Roblox will still try to launch into VR mode by opening SteamVR and connecting to a headset that isn’t there.

3 Likes

My suggestion for a hotfix is as follows:

There is a very shiny button in the settings menu labeled VR: on / off.
As far as I can tell this toggle doesn’t actually do anything but I may be wrong.

Make this option the ONLY condition for the Roblox client to attempt to launch in VR mode.
The only trouble that would result from this:

  • A player starting a VR session will have to quickly join any game (in normal mode) and turn this on and rejoin so Roblox launches in VR mode.
  • A player who has put away (disconnected) their headset but still has VR = ON will have Roblox open SteamVR in an attempt to launch in VR mode but it will fail and launch in normal mode. The player can then set the option to VR = OFF so it doesn’t happen the next time.

This would actually work even better than the current intended behaviour since you can actually leave your headset connected while having VR = OFF in the settings to prevent Roblox launching SteamVR.
The VR settings toggle even has the correct description of “restart pending” already.

7 Likes