Weird shadow behaviour

I am trying to place a tree on a platform with shadows off, but the problem is that shadows go trough platform because it haves shadows turned off.

Here is what i mean

As you see here the shadow of the tree goes trough the grass platform. I want the shadow to just appear on the grass. The grass platform has shadows turned off. Is there a way to make the tree’s shadow not go trough the platform without turning shadows on, on the platform?

3 Likes

Can you show me the entire properties list of the tree for example?


the properties for the primarypart of the tree, all the parts have the same properties expect for the size, position, color and material

1 Like

Is the part that the tree is on a Mesh or a Union of some sort?

It is a regular part, a cylinder. 2 of those on top of each other. Both have shadows disabled.

Does the ceiling have CastShadow on or off

Hmm, strange. I’ve never ran into that problem. Have you tried deleting and recreating the part?

All the walls and ceiling have castshadows off.

Try turning it on

This might be a dumb question, is your Roblox and Roblox Studio up to date?

I have tried deleting it and recreating it, several times.

Try turning it on

@gxxrde

It removes the tree shadow, but it instead adds another ugly shadow image

Yes, it is up to date.

(30 chars)

Open and reopen studio, might be a graphics issue.

Did it, it is still there. Both for me and the other person im in teamcreate with.

Let me see if I can get some other people in here, I’m running out of ideas.

1 Like

@index_nil You in the Roblox Discord and Roblox Dev Discord?

Do you have a Humanoid in any of these?

You must remove the humanoid from the models in order to fix this issue. Humanoids will typically show a shadow through parts, and is something that happens with all humanoids on any type of model. You can then use the “Cast Shadow” property (which you turned off) to get the same, or even better result. Ensure that you have ShadowMap enabled as well, in lighting.

If you cannot see the shadow in studio/in-game, it is because your graphics are low (humanoids will show even on low graphics, but the quality of the shadow varies).

Yes

Nope

(30 charrrrrrrrrssssssssss)

Right, try making the ceiling thicker.