Weird shadow behaviour

I made it 70 studs thick, no affect at all

Is it a union or a cylinder? If it a union, try replacing it with a cylinder and if it is a cylinder, try unioning it. (Not sure if it would have an affect, but worth a shot.

It is a cylinder. And when unioning it it had no affect at all.

Here’s two more suggestions that may work, just looking off of things on DevForums:

  1. Put a cylinder under the ceiling, the same color as the ceiling, just a tad lower.
  2. Mesh the ceiling (or vice versa if it is meshed) THEN enable CastShadow
  1. It did nothing, i dont see how that would change anything either.
  2. It just did what happend above, created a massive ugly shadow.

I dont think it is a graphical bug, as it has always happend for me and i have just disabled the shadows of parts then. But it looks really weird if the tree has no shadow.

Weird, this has never happened to me. I will look at further possibilities in a few hours. In the meantime, have you reinstalled Studio? I noticed you said your team create friend has the same issue, but maybe both of your Studios are bugged? I am really leaning towards this being an engine bug as it really never happened to me besides when using humanoids.

I re installed studio not so long ago, and i had that same problem before that. So i don’t think it has anything to do with my studio.

Are you sure that it is not happening for you to? You might have miss understood what is happening.

Here is a smaller example of what is going on.

The red part is the “ceiling/floor” and it has castshadow off. And the blue part is the “tree” and it has shadows on

I’m totally shocked by replies on this topic.
You see, because your ceiling and walls have CastShadow = false, shadows from objects above go all the way through both ceiling and walls. If you turn the property on, you’ll see that those weird shadows disappear. That will happen because they merge with shadows from ceiling and walls.
The clear answer is that the only way of solving your issue is turning on CastShadow.

1 Like

I have heard that all of the time, the problem is that i cant turn it on, as it looks awful then.

Guess ill just turn off the shadows on the tree, it will look worse but it is better than the alternatives

Fun fact: shadows from players above are also going to be visible inside. There are also going to be shadows from players inside, which is unrealistic (you don’t have shadows indoors).
You must turn on CastShadows to resolve this issue, deal with it. To make it less ugly, here are some compromises:

  • Changing Lighting.Ambient (it affects lighting indoors, set it to Color3.new(0.5, 0.5, 0.5) or brighter) (will make things ugly if you use pbr thing)
  • Adding light objects, but I think it’s a bad idea

I might need to change the lighting ambient then, i will probably need to script a bit to change the ambient if the player is close to the building or something. As i have other maps in the game that needs to have the current ambient.

Ah, yeah I definitely misunderstood the entire issue. That is something that does happen to me as well, with the middle block having shadows off.

As stated, the only way to really fix this would be to enable the CastShadow property. Now, maybe with the new future is bright update(s) there could be a possible fix to this issue.

Good luck with whatever project you have!