Weird Shadow Issue?

Hello! So today I was building for my game, when i noticed weird shadow issues! On the corners and stuff
you cant really see in screen shots but…




It’s REALLY hard to see in screenshots but if you play the game you can see it WAY better
https://www.roblox.com/games/4011873940/Noob-Simulator
they also move witch is SUPER ugly
I changed ambient and outdoor ambient to white/gray but it’s still there!
If you know how to fix this please tell me! Thank you!:upside_down_face:

Isn’t there a property on every part in ROBLOX that says, “CastShadow?” Maybe just set it to false.

1 Like

If that doesn’t work there may not be a solution since Roblox tends to draw brick face shadows regardless of lighting settings if the graphic quality is higher than 8.

Basically, if the render quality is higher than 8 it will render a shadow on the corners of all geometry, including meshes. This even happens if CastShadow is false on everything, GlobalShadows is false, and Lighting is set to “255, 255, 255”.

1 Like

Yes, that can happen aswell. Hopefully, disabling the CastShadow property works.

2 Likes

Unchecking the box under CastShadow should work:

1 Like

sorry i’m stupid apparently :joy:: Thank you!:upside_down_face:

Mark mine as a solution so people will know this has been solved. And no problem bud!

– Drinkinix :smile:

1 Like

Hold up! that didn’t help, First of all it getting rid of shadows makes every thing look weird. Second of all It still has that weird shadow that moves when the camera does, ?

join the game now, I got rid of ALL shadows. https://www.roblox.com/games/4011873940/Noob-Simulator

In Fact it’s worse?! Don’t know whats going on. btw it only happens when playing or testing NOT when I’m working or editing or whatever you call it.

That’s very odd. I’ve never seen anything like that before.

1 Like

I’m not even sure if those are shadows, they could be something else. But if it is something else I have no idea what.

I think I’ll just report it as a glitch! Thank you for trying to help :upside_down_face:

No problem. Sorry if I couldn’t find the right solution for you. :slightly_frowning_face:

1 Like

Its fine! this might be a bug so there might be no solution!

Have you tried lowering your graphics quality on the client? If it’s less than 8 and the issue is fixed, it’s unfixable.

1 Like

That worked! I joined the game and set my graphics quality to 1 away from the max and it got rid of it! But what happens if someone has their graphics quality to max? is there a way to not let them?

Unfortunately, it’s the way the Roblox Engine works. Currently, if the user has a Graphics Quality higher than 8-9, it will force shadows onto all geometry, including meshes.

The only work around is asking users to use a lower render quality.
I highly recommend posting a studio suggestion to disable this however! I myself have suffered this issue a lot, but I don’t have powers to post in studio suggestions I believe.

1 Like

The thing is that games like https://www.roblox.com/games/3823781113/UPDATE-Saber-Simulator?refPageId=b43fc5ca-510b-4ae3-aed3-2838e0b56377 i play with max graphics and it doesn’t have this weird type of shadow that moves.

It might be because it consists of nearly 100% meshparts.

I don’t know how the Roblox Engine handles the “fake-baked” shadows or whatever they’re called, all I know is that they exist and are very hard to get rid of.

It’s possible these shadows don’t exist on meshes because of the custom content of the geometry?