When I open ROBLOX Studio from the desktop app, Studio closes itself

So I’m having an issue where I can’t access ROBLOX Studio. When I try to access it by opening it clicking the app shortcut on the destop it will open then it will just close.

I have a Windows 10 PC

Not sure what beta features I have currently enabled

Expected behavior

I expect to see the issue is resolved if it’s not on my end. If it is I wish to get the upmost support I need to fix it.


try reinstalling roblox studio :pray: (because you didnt mention anything about reinstalling it thats why im suggesting you should do it now)

1 Like

Before you reinstall try pressing open or delete on the auto recovery file. I have the feeling if you just ignore it Studio tries to put it back in a server and crashes, becaus it ain’t giving the needed performance for starting.

I think linking your latest Roblox Studio log would be great help :wink:
You can find it in %appdata%/Local/Roblox/logs!

That reminds me of something…
Bloxy news (https://x.com/Bloxy_News?s=20) recently tweeted about the new anti cheat update. It caused players not being able to log in. The solution was actually to reinsatll the client. Credit to Chaseoroony: https://youtu.be/h4U7hsg-Beg

This has nothing to do with the Roblox player, Studio does not have Byfron tech inside of it (Hyperion) so that shouldn’t be a issue.

Also it seems like they are already authenticated, so logins shouldn’t be the issue.

1 Like

Currently having the exact same issue. I did a clean install of windows and everything (I needed to anyways and it game me an excuse to)

To my surprise nothing changed. Please let me know if you find a fix for this.

0.594.0.5940525_20230919T161545Z_Studio_2D268_last.log (33.6 KB)
0.594.0.5940525_20230919T161745Z_Studio_24F33_last.log (31.9 KB)
0.594.0.5940525_20230919T161857Z_Studio_C7151_last.log (32.6 KB)
0.594.0.5940525_20230919T162131Z_Studio_C58C2_last.log (30.9 KB)
0.594.0.5940525_20230919T162133Z_Studio_8AF84_last.log (31.0 KB)

0.594.0.5940525_20230919T141609Z_Studio_E3768_last.log (31.8 KB)
log_8AF84.ini (5.1 KB)

Here’s a list of all of my logs, (I assume they are similar to yours since we are having the exact same issue)

I think I had the same probleme, what I did is I just opened it as an administrator

For some reason this worked for me. Try it

0.594.0.5940525_20230919T183744Z_Studio_B62C9_last.log (30.7 KB)

Here is the latest log

I forgot to include that. I reinstalled studio twice. The issue didn’t stop there.

the only thing i found in the logs:

2023-09-19T18:37:52.279Z,8.279351,28d0,6 [FLog::Output] rbxCrashReason is: RBXCRASH-RBX::Runtime - panic
2023-09-19T18:37:52.279Z,8.279351,05d4,6 [FLog::Output] rbxCrashReason is: RBXCRASH-RBX::Runtime - panic
2023-09-19T18:37:52.280Z,8.280354,28d0,6 [LOGCHANNELS + 1] RBXCRASH: RBX::Runtime - panic (impl)

yeah this is pretty useless for me becaue im not roblox engineer

someone from roblox would probably understand what happend here just by seeing those 3 logs

1 Like

You had a crash | impl
Holy, 3 times.
Funny when it says panic :disappointed_relieved:
Yours happened today :sob:
You tried running studio | impl = you got your app crashed :fearful:

Any idea if a ROBLOX enginner will look at this?

1 Like

Alright I don’t know how I did it, but I deleted everything related to ROBLOX on my computer, I uninstalled both ROBLOX and Studio. I just reinstalled both and now studio is opening, I don’t even know what even caused it, however I do wish for a ROBLOX Engineer to still investigate this incase others are getting the same issue.

I watched the video, Delete all your recovery files.

I always do that when roblox does something stupid (starts random crash and etc)

usually fixes the issue after deleting all roblox related files and then clearing everything in %temp% with admin perms

Yeah. I guess it’s safe to say I resolved the issue, but for anyone else having the issue I had probably should look at this forum.


Hi all, we are actively looking at this and have made some changes on the backend. Can OP or anyone with a 100% repro try this again now and see if their experience is the same/different?

Does deleting recovery | %temp% files work?