Why isint hd admin working?

Hello fellow developers
I hope you are all having a good dy

I am currently making a new game and I wanted to add HD Admin to the game. But the problem is that every time I try to add it the admin does not work at all and it gives a few errors witch I am not quite sure what to do. The HD admin icon also does not appear (as if it wasant even installed)

If you have any questions (more information about my specific probleme) or any idea why its not working pls feel free to reply to me if you dont mind

Thank you


Make sure your using the right one while theres tons of fake ones.

1 Like

Can you please show the errors.

Here is a vid about the prob :

1 Like

Probably you get fake/virus one. Here original one: HD Admin


Probs use the actual one, or just the setting scripts to match your group/change the admin levels.


Make sure you are using the correct admin. There are millions of different fakes.

Here is a tutorial on the admin, which includes the model and setup instructions!

1 Like

First things I’d check:

  1. Are you using the official HD Admin model? HD Admin - Roblox

  2. Have you published your place to roblox?

  3. Have you placed HD Admin in ServerScriptService?


I personally avoid games with HD admin for fear of abuse through it, however I’m sure it’s just a glitch by it’s creator while trying to update it, it should be fixed soon.


I have done all 3
and it still dosent work

btw I never knew you had to put the admin folder inside of ServerScriptService
(The admin previously worked when the folder was placed inside of workspace for another game I have made)

1 Like

Workspace works, as far as I know, I used to put it in there but I like SSS better.

1 Like

Can we see line two of the code please? It could help us.


Also the link to the model you inserted, with errors.

1 Like

hey your HD admin is still not working and I have done all the things you told me to do.

Can you pls help me ??

1 Like

Errors? Where did you put the loader?


Make sure you’re using the official admin by ForeverHD only.


Make sure you’ve successfully saved and published your game on studio.


If none of those work, you may have to contact ForeverHD.

1 Like

P.S. If you don’t see an icon on the product, it’s most likely a fake model. (Check and make sure the model you’re using is only by ForeverHD.)


I did not move anything
I just added the correct HD Admin and that’s all

Is it a direct child of server script service / workspace? Or is it a child of a child of one of them?