Windows 10 UI scaling directly affects game resolution

Desc: Increasing the Windows 10 UI scale lowers the in-game resolution.

Monitor resolution 2560x1440, scale 100%, in game resolution remains 2560x1440

Monitor resolution 2560x1440, scale 225%, in game resolution changes to 1138x640

Other examples:

  • Monitor resolution 8192x4320, scale 100%, in game resolution 8192x4320
  • Monitor resolution 8192x4320, scale 500%, in game resolution 1638x864

How to reproduce:

  • Go to windows 10 System settings → Display → Scale and layout
  • Increase the scale above 100%

image !


Just going to confirm this-- very annoying and shouldn’t be happening, I prefer not to use my larger monitor for roblox because of this. I assumed this was on my end but this shows otherwise.

1 Like

I think this isn’t a bug.

Someone reported this as a bug and it got solved 9 days ago.

That’s a different bug. In that bug’s case, the game is normally low-DPI, but then alt-enter caused it to be extremely-high DPI, making the various GUI elements small.

In this bug’s case, maplestick is saying the low DPI behavior is itself a bug, occurring whenever the display scale is more than 100%.


Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


This also probably happens on Windows 8.1 and 7 (cannot test as my 8.1 laptop can barely handle Roblox and doesn’t have it installed and I can’t get Roblox working on any Windows 7 VM), reproduce by going into Control Panel and going into the Display section (if you can’t see, this change your view to Large or Small Icons) and press ‘Change the size of icons and text’ and finally choose a scaling level for all your displays and select something higher than 100% (e.g. 125%).

This same kind of behavior happens in studio as well on higher resolution screens. Seems the Roblox client on general does not like higher DPIs/resolutions.

This is still a problem now in late 2022. Developing on high resolutions like 4K is near-impossible without having scaling enabled, but then you get rendering problems and mouse problems. High-DPI screens are becoming more and more prevalent, and this is unacceptable for a company like Roblox.

EDIT: Apparently the DPI scaling beta fixes this, and it wasn’t enabling properly.
EDIT 2: Beta or not, half of the time, the entire studio window will only take up 1/4 of the space it can, and won’t render anything in the rest. This is still borderline unusable

EDIT 3: So as it turns out, Studio works almost flawlessly with 200% scaling and the DPI beta disabled… the beta is causing the DPI-related issues, which is shocking.