3D Sounds Broken

An engine update has caused bizarre audio behaviour for many users/games.

Reproduction Steps

Join this game: Wild Horse Islands - Roblox
Listen, you will hear “clicking” or “fireworks” in the distance. (Turn SFX in in-game settings to 100 if you don’t hear it)
These are horse hooves from thousands of studs away, these were not audible until today.

Expected Behavior

To only hear audio within expected range.

Actual Behavior

You hear audio from infinite distances.

Issue Area: Engine
Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-05-12 00:05:00 (-06:00)

Other reports of audio issues starting today:

10 Likes

I thought there were something up with my headphones when I noticed this, this is affecting every game, not just yours

Pretty sure disabling the FFlag SoundsRespectLongTailFx2 is a temporary fix?

2 Likes

Thanks for starting a thread. Definitely hope this gets sorted out soon, and definitely before next Thursday. The impact of this could be incredibly high for most games.

1 Like

This is affecting our game Pinewood Computer Core.

Given how we use a lot of ambient world audios, this is causing quite the ruckus when joining.
This additionally started happening for us at the same time as this post is reporting.

8 Likes

Yeah our game is pretty sound heavy and it’s very noticeable

2 Likes

After testing a lot of games, yes it a global bug. Every games that contain sounds seems to have the bug.

Hope Roblox will find a bugfix or reverse their update asap. :pray:

2 Likes

I can also confirm sounds play regardless of the in-app volume setting, this is a major issue for any sound heavy games that rely on spatial sound.

5 Likes

I thought it was just my game giving up; glad (not glad) that others are having this issue too.

1 Like

Video of this made by @aburtpoptart

6 Likes

My ears are currently bleeding :’(

1 Like

This flag has been disabled; could y’all try reloading and let me know if the bug is still happening? We are investigating

9 Likes

It seems fine for me now. Everything sounds the same as it did before today.

Disabling the flag manually with an override fixed it so I assume yes?

Yep, it seems to be fixed for me.

Thank you ! Seems also to be fixed on my side.

Perhaps a bit off-topic, but the now-deleted flag seems to have been SoundsRespectLongTailFx2. When implemented, was the fix meant to let sound objects play even beyond their file’s duration, given they had some form or reverb or echo post-processing added?
If so, this would be really awesome news, as I was having issues with it a couple months back :slightly_smiling_face:

2 Likes

Yeah! That was exactly the intended fix – without the flag, reverbs and echoes stop once the sound itself stops playing, which is a bug. Once we investigate the issue this flag caused, hopefully we’ll be able to re-enable.

7 Likes

This topic was automatically closed after 18 hours. New replies are no longer allowed.