Adding accessories to my giant NPC is a nightmare (help?)

REPRO: dummyrepro.rbxl (22.6 KB)

I’m simply trying to make my NPC wear the accessories I want. To be specific, my giant NPC:

Every single time I try to add Accessories to it, no matter what the method is, they appear really far away and with the complete wrong orientation. I’ve tried everything, including AddAccessory() and making the welds and whatnot myself. No luck.

Since this is using the R15 scale methods, the accessories do scale to the right size, they are just CFramed incorrectly. Is there any way I can fix this?

EDIT: Also the accessories and NPC have all the proper attachments inside them.


Are the accessories client side? If they aren’t added to the character on the server then they won’t connect to the character properly.

Well, since the giant is supposed to be the round’s winner, I do clone accessories that were parented to a Character model. They are never on the client though.

Could you go into more detail about how you have the giant and the accessories you’re trying to add set up? Are the accessories getting welded to the character, but are just in the wrong place? Are you sure the attachments on your character or accessories aren’t somewhere weird?

Can players see this giant NPC in game? Have you considered using camera tricks to make it appear giant by just making it close up?

Sure (sorry for the late reply)

Are the accessories getting welded to the character, but are just in the wrong place?


Are you sure the attachments on your character or accessories aren’t somewhere weird?

This character is straight out of the animation editor plugin, I just made it bigger with the R15 IntValue things (What do I even call those?) and changed its position. The attachments seem to be in the right place.

Yes, they can see it. This is a model that appears in my game lobby that players can walk around and look at and stuff, so camera tricks are out of the question.

1 Like

I don’t know if you have done this, but sometimes it helps to start a new studio session, and simply put code in to clone and size and do attachments for a giant character. It might narrow down the issue a bit.

I did that. Multiple times. It didn’t fix anything.

I will try it, and see what results I get, what accessories are you attaching,and exactly how giant are we talking about

I tried cloning my character in a server script, when touching a block, I scale all the values in humanoid by 3, then I try to attach a wing accessory, and it seems to be connecting properly.

well I was going to post the code, but I cant figure out how to do that on here.

Edit: I also tried it at 10x the size, and then 30x the size, and I tried it with the Animation Plugin Rig Builder using the Block Rig. Still seems to be placing the wings at the correct size and position.

1 Like

You can see the original down by the foot of the giant one.

If you upload a simple repro file of the issue, it will be easier for others to help debug and provide a solution.

1 Like

I don’t know why I didn’t think of that. Thanks. I put the repro in the OP.


You’re going to hate this.
Unanchor the dummy’s head.


I can’t believe it was that simple. Thank you so much!

Is it documented anywhere that having the head anchored will produce unexpected results like this?

:-) Not for accessories. It’s weird behavior related to Welds, which isn’t documented for welds either.

Cool. I’ll make a documentation request.

Also, if ever you want to copy your character in studio, in a certain pose, if you anchor your head, all the accessories will go flying off in weird positions as well. However, I did not know that it still did this with R15, I have only recently switched from R6, so… this is good to know that its still an issue.