After most recent update, games in Studio AND played on Roblox proper will never load properly

System Info: Macbook Pro Mid-2012, OSX Catalina 10.15.7, 16 GB memory

Since the update from today, nothing has loaded fully. This is occurring on both Studio and every game. Yesterday, prior to the update, nothing was amiss. Now games are unplayable and I cannot work on Studio at all.

Examples in game:

Lab Experiment - Decals, most item assets and textures not loading at all

Free Items Game! - Decals, most item assets and textures, animations not loading at all

Studio has an extra issue where opening a world that will not load makes you unable to open it again, returning an error.

Examples in Studio:

Normal, unmodified 2022 Baseplate. No textures, no skybox, no decals.

Screen Shot 2023-06-18 at 8.55.25 PM
Error message that returns when attempting to reopen the same place.

Expected behavior

Everything loads normally in a matter of a few seconds to a minute or two if I’m experiencing lag.

A private message is associated with this bug report


Can confirm I have just started having this issue recently as well. I believe yesterday is when it first started happening for me. I have tried clearing cache, restarting my PC, and even reinstalled both Roblox and Roblox Studio. None have worked in fixing this. Hopefully this gets fixed quickly as at the moment I am limited to only scripting in studio and can’t do any play testing in game.


Yesterday, I encountered a similar issue where, after closing Studio, all assets failed to load when I reopened it not sure if this was the cause of the issue. I tried various methods I found online, such as flushing and changing DNS settings, clearing cache and temporary files, and reinstalling both Roblox and Studio. Unfortunately, none of these solutions seemed to work. Initially, I thought it might be an internet problem, but when I tried joining the same game on mobile, I didn’t experience any issues.

When opening a new place this happens:


same this has been happening and it has been making games that i normally play, unplayable. games like deepwoken and arsenal will have enemy models either not load in at all or animations won’t load


Thanks for the report. We’ve filed a ticket in our internal database.


Day two update: still occurs, but it’s a little better.

Free Items Game! - Decals, clothing, most item assets and textures (but less than before), meshes, various body parts, animations not loading. Materials are now loading slightly at least.

angel’s sensory room - Clothing, most item assets and textures, some body parts, most meshes, skybox, most light sources, some materials, most animations not loading


Glad to hear this, but is there any word on when a fix will be pushed? Currently development and playing Roblox is impossible because of this issue, so this is pushing all of my plans with my projects back.


games seem to get better and better at loading stuff the model you play it, but if you don’t play the game for a while it’ll go back to how it was originally, where nothing would load. at least this is what i have been experiencing


Reassuring to hear that! I’m experiencing the same thing as well as others listed in this post: We CAN’T use Roblox! - Help and Feedback / Platform Usage Support - Developer Forum | Roblox


Yeah, no fix seems to work. So, yours works fine on mobile but not on PC? That’s interesting, because I have the issue on Windows, Mac, iPhone, and XBox.


It seems to be very random on what assets load in and what don’t. I get different results each time I rejoin an experience or open a studio file, but every time there is an issue. On Studio, the default Baseplate Skybox never seems to load in nor do most default materials or the studs and SpawnLocation Texture.

1 Like

I am experiencing the same issue. On games with larger server player amounts, it is a lot more prevalent.


Attempting with my Shadow (Latest Win 10, 12 GB memory), Roblox just… crashes, or doesn’t open at all.

It even sent me TWO errors at once one time I was trying to open it:
Screen Shot 2023-06-20 at 2.38.29 AM

Normally it’ll just send the “Roblox needs to quit. We’re sorry!” message but that time I got an auth error too.

This is a really major bug and needs to get fixed ASAP.


For any of you guys having this issue, changing your IP Adress fixes the issue. I was hesitant at first, but it did the trick. I’m using ProtonVPN, it’s simple and free. There are probably better options, but it gets the job done! That being said Roblox still needs to resolve this issue, because not everyone is going to know this nor should everyone have to change their IP to use Roblox.

1 Like

I can vouch on this, I changed the IP address on my router and it seemed to work. But the cause of this issue is still unknown for me.

1 Like

Using a VPN did work for me. One thing to note is that this issue was happening on all of my devices (even on mobile) so it must have something to do with your location and not the app itself.

Currently facing package-loading issues via LoadAsset() and a random set of plugin icons fail to load each time.

Unsure if related.

Can confirm this happens in Jailbreak. Unsure if it’s the developer’s fault, but sometimes some assets aren’t visible or the skybox will appear in black.

However, this has been happening before this post too.

Could it be StreamingEnabled sometimes too? Throwing myself into the pool with this idea, but besides the already occuring bugs I believe StreamingEnabled could be taking part in some of these cases.

If this is true then that means there might be some exceptional network replication issues (I doubt).

1 Like

I saw a post a while ago about this same kinda deal being an Xfinity issue. Are you also using Xfinity or Comcast?
Also, VPNs don’t seem to have any valuable effect in my instance.

Edit: Adding that I’m in the Atlanta area, doubt everyone else is too - but if it’s IP based, it’s gotta be an ISP thing.

I use Verizon, and my Shadow uses something else. This is not related to ISP.

I have a dynamic IP so it changes anyway, but I’m not SEEING anything different. The same bug occurs.

All games are affected. I don’t use StreamingEnabled because it crashes my Studio, and my games are similarly obliterated.