Align positions have no properties

Reproduction Steps
Add an align position to any object in studio and select it.

Expected Behavior
I expect to see properties in the properties window

Actual Behavior
there are no properties in the properties window

Workaround
setting all properties by script.

Issue Area: Studio
Issue Type: Display
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2021-07-07 00:07:00 (-05:00)

15 Likes

I can reproduce. Latest studio build, x64 windows pc. Noticed yesterday, I don’t know if it was there before too. I tried restarting and reinstalling studio too.

3 Likes

AlignPosition is not released yet.
edit: nvm

7 Likes

Is AlignPosition not an already documented API as seen here or in this article on the wiki? I have definitely used AlignPosition in my work before.

Oh sorry, idk why but I was thinking of the LinearVelocity constraint. Yea these should be showing up and will be looked into

8 Likes

This has been happening since the 10th when I first saw it reported and I commented on it.
Link to the post from the 10th. Align Position properties not showing up
(I’m not the OP, I tried to put it in bug reports and make a new thread but it wouldn’t let me.)

oh oop, i tried searching to see if this has been posted before and didn’t see anything. Guess we should get a mod to merge the threads

1 Like

The other one wasn’t in bug reports, which is why it wasn’t found. I’m not sure why I wasn’t able to post a bug report about it either…

Just a reassurance for anyone who runs into this: The properties have not been lost, and you can in fact still set them from scripts / the command bar just fine, this is only a display issue in the properties pane.

6 Likes

any idea when this will be fixed?

3 Likes

In the meantime it’s easiest to just use the command bar to print and set properties of AlignPositions as needed (if it’s not just set directly in code)

1 Like

The issue has been fixed in today’s Studio release, sorry for the wait.

7 Likes