Anchoring a pose with the Animation Editor no longer works?

Like a day ago, they completely changed the Animation Editor.

Everything about it is different and it’s supposed to make animating better, which is great and all…but
now…it’s sorta…impossible to use for GFX projects…

Before, you could anchor avatar poses while having the Animation Editor open. ( Shown in this screenshot of a render tutorial. )

But now, the anchor button is greyed out whenever you use the plugin at all.

Clicking off the plugin to do literality anything else just gets rid of said pose, so that’s not an option.

Right clicking on the avatar while using the editor does nothing as well…

I really don’t like the fact that they changed this while updating the animation editor, lots of GFX artists use the plugin to get started on their projects.

People may say “just switch to blender to bend limbs” but the editor is meant for posing more complex rigs like R15 or Rthro or avatar packages for example.

The fact that it’s completely useless right now makes this a huge issue in the GFX community, the only reason nobody’s talking about it right now is because it’s a new problem.

If there’s a different plugin to use or a way to anchor this without losing the modifications on the rig, please say so.

6 Likes

Hello. I may have a solution to your problem (I havent tried this actually)

Before the animation editor updated, the way I lock poses wasnt anchoring, I actually select the body parts one by one and moved them a tiny bit with the Move tool (It doesnt even have to move, clicking any arrow will lock the part in place). It might take some time but it is potentially an alternative to anchoring. I havent tried this yet (since making GFX isnt my job in my apartment) but i suggest you give it a go. Hope this helped.

2 Likes

To be clear, your need here is to be able to quickly pose your character in the editor, and then extract that out for other purposes in your workspace?

Here’s a quick workaround for you to paste into the Command Line. Note that you won’t really be able to edit the cloned model, since it actually changes the base pose of the joints for the clone. However, if you simply save your original posed model, you can delete the previous clone and make a new one if you need to update the pose.

Note: this relies on your model being named Dummy and just being in workspace. You can change the first line if you want that to be different.

local model = workspace.Dummy

local clone = model:Clone()
for i, v in pairs(clone:GetDescendants()) do
  if v:IsA("Motor6D") then
    local counterpart = model:FindFirstChild(v.Name, true)
    if counterpart then
      v.C0 = v.C0 * counterpart.Transform
    end
  end
end
clone.Name = "Clone"
clone.Parent = workspace

This works because entering this into the command line doesn’t make the Animation Editor stop editing your rig. So it’s basically capturing the current pose from the editor and making a copy of it that the Animation Editor doesn’t necessarily know about.

12 Likes

Basically, yeah. The editor is used for a lot more than just animating which is why the auto-pausing feature comes off as annoying to non-animators who use it.

Wow, your code works better than i thought. Thank you!

This can definitely help a lot of GFX artists who run into this anchor problem in the future, awesome job!

1 Like

I made a plugin that can help you.

3 Likes

Tried it and it also works perfectly! Thanks!

Linking it here incase someone else struggles with the anchor problem.

8 Likes

I had the same problem with anchoring poses with the new Animation Editor, too. Well, thanks to the plugin, it works!

Hey i tried it but the pose didnt come out on it