Animation editor: issues with rig part selection and camera zooming

When using the animation editor plugin, I constantly get really strange and seemingly random bugs.

  1. For example, occasionally, the blue vertical bar indicating which keyframe you are editing becomes unable to be moved side to side and instead can only be moved by clicking on the desired point in the animation, which instantly moves the bar there.
  2. Another is that fairly frequently, I become unable to click on a desired body part to pose it and instead have to rely solely on clicking on the parts in the list.
  3. There are also seemingly random times where while trying to click on something or pose something with the editor open, my camera will just start zooming around studio while getting faster and faster, and the only way to stop this is to restart studio, because when you close the animation editor thinking it will fix the issue, then reopen it, you just start zooming around again.

I managed to get all of these bugs to occur within the same 20 minutes, which is kind of a big issue. I don’t know if anyone else is experiencing these problems, but they’re certainly making it near impossible to get 1 simple animation completed. Here are some gifs:

Inability to click on body parts: https://gyazo.com/60a4e29c8aab99510e0802ea0996b168

Zooming around the map (I’m not even touching my keyboard): https://gyazo.com/0cac72b42e4fe42366a6776547b5fc71

Body parts won’t stop being highlighted and blue bar stops being draggable (These two happen simultaneously):

21 Likes

I have been experiencing all issues listed above and some new issues I’m listing below for a long time.

  1. Several parts tend to get selected when I move my mouse across the screen when I’m not holding down any buttons. Right after this, the scrubber stops working, and closing and reopening the animator fixes it, but it always happens almost immediately after opening the animator and starting the animation.

  2. Unable to click on parts in the workspace. Most of the time, the parts farthest from the Root of the model are impossible to click, and can only be selected using the list.

  3. When using the camera to look around the object I’m animating, sometimes the camera will start to zoom quickly and I can’t escape this unless I exit studio.

  4. Some body parts deselect immediately after being selected when selecting it in the list. This is frustrating because if they are unable to be selected in the Workspace too, the part is impossible to select.

  5. Using the click and drag to select multiple keyframes doesn’t work. One of two things happens when trying to draw a selection box: The box doesn’t get drawn at all, or the box is very small and doesn’t select what you tried to select. Using SHIFT or CTRL to select more than one keyframe only works sparingly, and if you select more than 3, sometimes they will all randomly deselect.

Here is what the Output looks like:

I hope these issues is addressed. It makes animating very difficult.

2 Likes

An update on some of these issues.

@Crying_Rn and @ShinyGriffin the first issues are the same. There a bug with studio scrolling frames in general, and our studio team is currently in the process of fixing it. From what I’ve seen, the only workaround until a fix goes live is to always have the animation editor large enough such that it is not scrollable. Please try that and let me know if that is not the case.

The camera zooming uncontrollably problem: we are aware of this, and believe the issue has to do with how input is handled on plugin gui widgets, not necessarily the animation editor itself. We are trying to get this fixed, but in the meantime there may be a way to avoid this behavior. It seems to always happen if you are controlling the camera (with wasd), and have the mouse down in the animation editor at the same time, then if you move the mouse out of the animation editor while still having it clicked down and you still have one of the wasd keys pressed and then let go of the mouse, the bug will occur. Please try to avoid doing this, and if you encounter any other ways to reproduce the behavior, please let me know.

For being unable to select body parts in the workspace: This is also a strange input bug that we have had trouble reliably reproducing on our end. If anyone has been able to identify a consistent list of steps in getting this bug to appear, it would definitely help accelerate us fixing the bug.

@ShinyGriffin, can you tell me what issue you listed is related to the output you posted? There was a bug that appeared late last week that was causing a similar issue to what you described in #4, but that bug has been addressed since then. Can you check if you can still reproduce this behavior?

3 Likes

Thanks for the advice on how to workaround the bugs, its very appreciated.

This is a reliable way to reproduce the issue of not being able to select parts on the model:

Create an original model with approximately more than 10-15 parts and rig it using Motor6D joints and animate with an Animation Controller, not a Humanoid. The parts physically closest to the Primary Part are the only ones that can be selected in the workspace, and usually, the parts furthest from it cannot (Although sometimes it fluctuates and I can select them only if the camera is at a very specific angle). No errors appear in the output when this happens.

This specific model has around 30 parts, but my other models with only 15-20 parts have the same issue.
image
image

For example, in this image, parts Tail1 to Tail1c can be selected, but anything beyond that I cannot select in the workspace.

The output error I listed occurred when I was trying to select a part from the animation editor and it was immediately deselecting.

I also found a temporary fix to the scrubbing issue. When the mouse randomly selects several parts, the scrubber stops working simultaneously. I noticed that I could fix the scrubber by taking a keyframe and moving it around. The scrubber starts working again after that.

a

Thanks! Is there any possible way you can PM me an rbxm with one of the rig’s you are using where you see the problem?

1 Like

Yes, I’ll send you the model in a PM.

Today I’ve encountered a serious issue though. The animation editor is not working at all anymore. When I select a model to animate, the editor turns black, and when it’s closed, studio crashes. This is what it looks like. My models are animated with AnimationController. My partner who is in Team Create with me on the same place is experiencing this as well and we both are having this issue.

This is what appears when the editor is opened. It turns black, and this only started happening today.

This is what happens when I select a model. The camera locks onto the model and I get an input error.

This is what happens when I exit the editor with x:
image

I feel like this is serious since it’s a 100% reproducible studio crashing bug. Any help would be appreciated!

1 Like

Thanks for letting me know. This was a feature that was just turned on. Can you try putting a humanoid on the model instead of an animation controller and see if that’s a workaround that will unblock you for the time being?

2 Likes

Thank you for getting back to me quickly!

I tried to workaround by putting a Humanoid instead of the AnimationController, but I’m unable to replay or edit my animations I worked on previously.

By taking out the Humanoid and animating with the AnimationController, a blank screen shows up:

Try setting the HipHeight property on the humanoid to 1.35

Edit: One of the features was turned off. Hopefully you should no longer be experiencing this bug and can use the animation editor with an Animation Controller as normal.

2 Likes

Thank you so much! It’s working normally again.

Having these exact issues right now. It’s literally impossible for me to use the animation editor because the camera is just zooming at gradually increasing speeds, and body part selecting just flat out breaks.

1 Like

Exact same problem, by any Cuba vice are you on Mac? I’ve found a way to solve it. Restart studio. It’s annoying to do every time, but it works.

I’m not on a Mac, no. I’m on PC (Windows).

Dealing with the same problems here, although the part selection problem does not fix itself when I restart studio while the other two issues seem to disappear for the time being.

3 Likes

i have these same problems, although idk if these bugs were ever fixed and have been occuring lately after a studios update but the animator editor does the same thing to me
as seen here for example e - Roblox Studio (gyazo.com)
this has been happening to me multiple times, also alot of my rigs have over 70 joints, but this only had less then 50 so idk what’s wrong :confused:

This is happening to me now too, Sometimes, the selection box will not appear and there will be no way to select a part that isn’t already in the animation.
The main problem is, while looking at this topic, i see that the rigs involved usually have 10< joints, meanwhile, i’m having this problem with 2 parts and 1 joint.

Is there a modern solution to this topic anywhere?

2 Likes

I am having rig part selection issues as well.

2 Likes

okay so i have found a sort of fix to this (im going to link the animator plugins i use after this) but i turned off pivot in the beta features in studios and i am now able to animate with my old animation plugin and then edit the frames in the new one, so i think it has to do with the pivot feature still not sure. hope this helps


and here is the plugin Animation Editor 2016 - Roblox pretty sure the other plugin in i marked as old is the default roblox one since i dont see it in my inventory