Annoying lighting bug

In Studio, when anywhere close to terrain and/or an object, there is a flashing shadow around it. This started happening for me yesterday and is quite annoying

Video of bug:

Is anybody else having this problem, and if it has been solved, please tell me how ;p

I am new to DevForum, so please let me know if this is poorly formatted or placed.

(and yes, that’s a fake name on the video :wink: )


Hi I’ve got little knowledge of the problem however it could just be a bug caused by how you’ve built the terrain, try smoothing and or adding pieces.

On a lighter note this is the correct place for his problem. :grinning:

Thanks! On the map shown in the video, there are sections with flat, painted, and no terrain. This is present on all.

This bug only happens on that game and the other developers say they don’t have it – it’s only me as far as I know.

I did realize that this problem started right when sun shadowing was released, not sure if that’s related.

Just found this topic, have a go trying the solution.

1 Like

This could also be a bug with you personal rig, try lowering your graphic settings ect. If this doesn’t work have a go at tweaking the games lighting settings.

Near the origin, the flashing is a tad better. It does seem to be the grass texture that makes it fire up.

I have also noticed then when play testing it isn’t a problem, just when I’m editing.

1 Like

I think in the terrain editor you can change texture colours, try making the grass colour a lighter shade.

I’m not seeing that option in terrain editor.

Is this a bug in game or just in studio?

This bug only appears when not in playtest in Studio.

Okay so in the Workspace there should be an item called “Terrain”; (Files are separate for my game)

Then open the properties tab, click “Materials” as a property and you should be presented with the following menu.

I hope this helps.

Can you provide your computer’s specs? (ie. GPU, CPU, RAM, etc.) Make sure you’ve rebooted your computer recently, and look into updating your graphics drivers. If this issue still occurs afterwards you might want to look into reporting this as a bug via the post approval process.

1 Like

i had this problem too the solution is to set lighting technology to compatibility