Audio previews often fail to play

Bug
When I attempt to preview an audio on the catalog, it does not play the audio as expected.

Repros
https://www.roblox.com/library/1837059570/Venture-Beyond
https://www.roblox.com/library/1836885340/Best-Endeavours-Ol
https://www.roblox.com/library/1835124514/Illegal-Download-Main-full

Browser Console Errors
The following errors are printed in my console each time I try to hit the play button to preview an audio.

Information
Operating System: Window 10

Browser #1: Chrome
Browser #1 Version: 75.0.3770.100 (Official Build) (64-bit) (cohort: Stable)

Browser #2: Firefox
Browser #2 Version: 67.0.4 (64-bit)

30 Likes

Can you add an example of an asset (link to page) that does not work for you?

1 Like

I’ve experienced this too, happens on quite a lot of audios I listen to. Works on one and doesn’t on another.

15 Likes

I’m also getting this exact error when trying to play audio on the catalog, although it doesn’t happen everytime which is weird; it is random.

3 Likes

I can, but it happens on every audio I try to preview so there is really no point to adding an audio asset. Even the new audios Roblox uploaded I was unable to preview, so I am sure that it wasn’t just an issue with the audio was trying to preview.

2 Likes

Even if it happens on many assets, please still include an example that they can try to repro this with. A repro is better than no repro, and it may not be happening with all assets but just the ones you tried. You never know, so include the information anyway.

2 Likes

Ever since ROBLOX made it possible to preview audio in a player’s Inventory, I’ve also been unable to use the play button on all audio.

It just shows up like this

image

Additional info

  • Using Google Chrome
  • I am using the following extensions, but disabling them does not change anything:
    AdBlock & uBlock Plus,
    Roblox+
  • I am able to preview audio very rarely, but only on random audio.
  • Sometimes, the play button will still appear but whenever I click it, it instantly stops the audio
  • Unsure if worth mentioning, but yes, I have the latest Adobe Flash Player
7 Likes

The bug appears to have been fixed as all audios in the catalog appear to now be playing correctly including the ones I listed.

After doing some more testing, some audios that I’ve previewed don’t play on the first click.

For me I still have the bug, it will only play audios that I have played before, everything other is unplayable tried click more than once and 2 and 3, nothing happened.

Information:
Android 8
Google Chrome 67.0.3396.87
Samsung Galaxy S9+

2 Likes

There’s even instances where it wont play no matter how many times you click play.
I’m guessing this is a loading issue.

2 Likes

same issue here in 2018 google chrome still it play other times not and not play at all it drives me nuts to use edge to preview the audio just fix the audio preview i run latest versions on chrome and windows flash player

The first two in the OP were broken for me, but the third one was fine. When I re-loaded the page, they were fine. I can’t seem to get them to break anymore.

Quite often, if it breaks for me, this displays:
image
But other times the play button is there and it still won’t play!

5 Likes

Can confirm I have suffered from this for many months.

5 Likes

I’ll post on this thread since it contains more info (merger on the other one possibly?)

Can confirm this issue is also on Firefox, it’s not only a Chrome problem. Firefox 61 on Desktop and Firefox on Android 61.

3 Likes

Audio doesn’t play on the website. This happens most commonly with short audio (< 1sec), but is normally random. You can easily reproduce this by opening a bunch of random audio assets and attempting to play them. This happens on everything except Studio toolbox.

Attempting to click play flashes the button and the audio doesn’t play
audioBug

This bug has been occurring since user-generated audio came out years ago and still hasn’t been fixed.
I’m currently using Chrome but I believe this happens on any web browser.

15 Likes

I’ve had this issue ever since 2014 when I joined Roblox…

I thought I was the only one experiencing the issue, I guess not though :stuck_out_tongue:

But yes, a fix for this would be sweet because I’d rather not have to go to those “Radio Testing” games just to hear how an audio sounds.

1 Like

This is a long standing bug on Chrome. I use Microsoft Edge to play audio, because it works for some reason. The error I get in the console suggests otherwise because GET error appear for the assets.

1 Like

I wasn’t aware an issue like this exists. Then again I use Roblox+ Extension so that probably fixes it somehow.

1 Like

Have this same error.