Black outline appears when scaling images

My vote is always there for premultiplied alpha.


I took a shot of it right now though:

Will it be rolled out later on? Will it only work on newly uploaded images?

You probably have to reupload the decal as mentioned earlier.

@buildthomas is correct.

You’ll need to reupload. Sorry for the inconvenience

I’m having this issue right now. You can find more about it here.

Sorry for the bump, but it appears that 2 years later it still isn’t fixed.

New uploads?

Yep, this tutorial was made only 2 months ago, if it was fixed there would be no need for the tutorial. I haven’t really experienced this issue as I don’t work with UI often, but I was having some weird outline problems with small images only a few weeks ago.

bumping. I’ve been using decals for a build, and these black outlines are a nuisance.


Is there any idea when this will be fixed? It’s annoying how my loading icon has a black outline around it.

1 Like

This is fixed, the site no longer mangles the color of transparent pixels. You will need to make sure your source image is correct. If you have black transparent pixels next to an opaque color, that will still have a black outline. The site doesn’t do any kind of fancy color correction if that’s what you’re wondering, that’s intentional.



The problem in OP is still not fixed as you said yourself that the site doesn’t do any correcting so you still have to manually correct everything yourself.

Please read again what I said. You are meant to correct this yourself. File a feature request if you think the site should re-encode transparent pixels to have the colors of the nearest opaque pixels, it’s off-topic here.

This bug report was, based on the responses here, about the site re-encoding all the transparent pixels to be black transparent instead, which guaranteed that black outlines would be present on the image.

1 Like

Almost 6 years later and still no fix :confused: Before anyone tries to link me to any of these

Please note, these DO NOT fix the problem on mobile. While UI looks clean and crisp on PC, testing on mobile still shows they black outlines. I believe this is a bug tho, as it did fix on mobile when I used PixelFix, and the UI was looking clean and crisp. But when I play tested the next day, it was back to the old ugly black outlines. Still same images, so I don’t know what’s going on with the rendering or something but ye.

This video was taken when I had fixed the UI with PixelFix. As you can see, the buttons and their icons don’t have the black outlines.

Then the next day I join and I’m greeted with the ugly black outlined UI again

The button images in studio are referencing the PixelFix images, so I don’t know if images get their quality ruined after a few hours after upload or what. But this bug still isn’t fixed :angry: making UI for mobile a near impossible feat sorry, I should say GOOD looking UI a near impossible feat

I have some further proof this is still an issue. Image1 shows robux icons taken before the pixelfix (with time stamp)

Image2 shows it after pixelfix (taken 2 minutes after previous image)

Then this last image shows me on a few hours later (3 hours after I did the pixelfix) and the images have reverted to black outlines

Can we please get some word that this issue is being taken seriously? Really hindering my games progress


This annoying thing, it’s making doing some waves on my game impossible. Just look at this.

What’s up with that line on top? It looks super bad.

When are we getting a fix for this? Im tired of using pixelfix for all my images. I just want to make UI, not do image processing for every icon I upload

1 Like

Bumping this up again, because with the images uploaded having Bilinear Interpolation, the only alternative is to scale the image down to the exact offset, however, doing so would cut the image’s quality. It has been years since this issue has been brought up and many of us are all looking forward to a fix.


It’s funny how long this thread has existed and the initial problem STILL hasn’t been fixed. I’ve been dealing with this issue over and over. I use photoshop and the plugins recommended in the tutorial by Quenty are outdated now.

1 Like

Bumping this up ONCE AGAIN. I still have the same issue even when using Pixelfix… this is starting to be a joke, when will this be fixed? Roblox is concentrating on graphics and real looks but wont fix this issue.