Can't change personal text on profile

Since one week ago I can’t change the text on my profile page anymore. I tried it on different computers without any result.

When I typed a text on my profile in the settings and I press save, nothing gets saved. When I reload or check my profile my old text comes back. I’ve waited at least 24 hours to see if it was just cached with my old text, but it never changed.

This bug repeats constantly on different devices. I tried changing the text on a Chromebook (Chrome OS 79.0.3945.86), Windows 10 computer (Google Chrome 79.0.3945.86) and an Android 10 phone (Google Chrome 79.0.3945.86).

I already tried the incognito mode, clearing cache and clearing cookies. I also tried logging in and out different times.


Have you tried restarting your computer? Most of Roblox’s features may be outdated if you do not restart your computer at least once a month. Maybe there’s the problem occur?

I’m having this issue too and it’s super frustrating…

@Schedency I’ve restarted many times.


Restarted many times, did everything which is possible at the client side.

Switching browsers does not work either as it’s not a problem which occurs only on Chrome.

1 Like

Thank you for the report! We are looking into it.


Update: This appears to be resolved, at least for me.

Thank you to the team behind this fix!

1 Like

Yes, it was resolved for me as well.

This still doesn’t work for me ):, if it’s relevant I do have a pin but it is unlocked before hitting save


Already tried that, disabling pin and so on. Last time I tried to change it, it was published after one hour of saving. But sometimes it doesn’t save even after waiting days. I think it is a caching issue at the server side.

1 Like

I don’t know if it is related but, it will not allow me to edit my friends aliases. I can edit the info on my profile just fine. I’m using Windows 10 and Microsoft Edge version 44.18362.449.0.

I think that they all are caching issues, also like this bug.

This bug causes any changes to the about section (located on players profile) to not be saved, even though when “Save” is clicked the box that pops up says “Saved Successfully”. I have noticed this bug on Roblox for the past 3 days.

How to reproduce

  1. Go to!/info
  2. Make changes to the about section.
  3. Click save.
  4. Go to your profile and notice the changes did not apply
  5. Go back to!/info and notice that the changes have been reverted

It doesn’t reproduce all the time, but when it does, it reproduces 100% consistently for a long while. The issue may be caching related.

I tried disabling all browser extensions and got the same results. I have also cleared my cache and tried changing it on my phone, also leading to the same results.

I am on Chrome 64-bit (80.0.3987.106) and Windows 10 64-bit (1909)


That’s probably related to an update which is rolling out to a small percentage of users. Check this Tweet for more information. :wink:

It also needs you to enter PIN in the Account Settings then go back to the profile (If you have an Account PIN). Why lol

1 Like

Yes I’ve been noticing this as well, it’s so annoying.


Same here I see the same thing, its really odd and I thought it was because of my ban last month, but its really annoying that this is a problem. Though I’m hopeful that the good people at roblox will fix it.

Marked as solved, @AzRollz @ToddSchofield please file a new bug report if you still see issues