Can't Connect to Any Game with VPN

VPN Leads to Connection Error

While connected to any of my 3 VPN’s (Azure VPN, McAfee, and Norton), I am unable to connect to any Roblox game.

I receive the following error when I have my VPN on:

Steps to Reproduce:

  1. Turn on a VPN
  2. Try to Connect to a Game
  3. Receive an Error

Systems information not relevant as this happens multiple computers (different networks too).

It is understandable to take extra security precautions with allowing studio access to VM’s, but it should still be possible. Consider adding a human verification wheel for VPN connections.

It would be much appreciated if this could be fixed as I (and hopefully others) realize how important having a VPN is today.

Related: Can't Connect to Team Create on a VPN


I have the same problem with TunnelBear for the most part, although I have successfully gotten into games with it enabled once or twice.


Weird, I was able to connect to games multiple times using Private Internet Access and BitDefender VPN/Hotspot Shield.


This is an issue. I used to have ad blocker on my phone and randomly it used to say “please check your internet connection” error message when I was in a middle of a game it was very frustrating, my internet connection is fine. So one day I decided to turn it off and it didn’t happen again. I think that happens with a VPN is to stop people that are IP banned from playing roblox. Just my idea.


Maybe roblox reads users with a VPN as no internet, reply this if I’m wrong


Not everyone and everything is perfect - it looks like the Roblox scripts cannot detect those VPNs. It’s not weird, it’s expected. It’s like using a good paid VPN service such as Cyberghost in order to bypass limitations on platforms such as Netflix and Disney+.

1 Like

The effect appears to be selective, I am able to connect with some VPNs.

We are looking in to options to try to make this happen less.


Can reproduce using my OnePlus 7 using Browsec VPN. Works just fine if I turn it off, but never works with it on, ever.

We just modified a setting that may help, please try again and let me know if you still see the same error.


Seems to be much more reliable, at least for Tunnelbear. Was able to successfully join 3 times in a row. 4th time I got a generic ID=17 error, which I’ve never had as an issue - might just be related to the fact that I somehow teleported from the US to Canada to Brazil in 3 minutes.

At last, I can enjoy my 800ms ping in peace. :slightly_smiling_face:

1 Like

This appears to have fixed it, thank you!
Maybe you could also take a look into this?

Weird. I’m able to connect using NordVPN before they rolled out the setting change. Well, it works now!

with respect to VPN, TeamCreate connections shouldn’t be treated any differently than normal game connections. Is the issue with TeamCreate still happening on VPNs that you can connect to games on?

1 Like

It seems to be much better, but not completely fixed. The error still happens but reopening studio seems to do the trick.

1 Like

do you have to reopen studio every time you want to open a team create place, or you needed to reopen studio once and now studio works as expected?

1 Like

The specific TeamCreate place I am working on is a place in a universe, and therefore must be opened from the develop tab of the website. (Unless there is a direct way to open it from the Studio menu which I am unaware of.)

This still appears to be an issue for me whilst using Norton’s VPN. Every time I hop into a game with it enabled it’ll simply infinitely load or if I try to use Roblox studio’s team create it also errors, however, once the VPN is off both these issues appear to go away.

It is a possibility that it could just be my VPN, but I thought I’d bring it up incase someone else is still having this issue too.

1 Like

I’m having a similar issue where I can’t even connect to play games while using a VPN. I am using Private Internet Access. Team Create connections seem to be fine, but connecting to a live server is not.

This issue has actually been coming back lately for me as well with Tunnelbear. It’s like a 1 in 8 chance of successfully joining the game.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.