Can't drag a GUI object in studio

Hi there! (Sorry if this is the wrong category, please let me know if it is.)

In a certain game, I can’t drag UI objects in the studio, but I can in different games.
This affects all UIs in StarterGUI.

Please let me know on any solutions, thank you! :slight_smile:
- Itz_bobbeh.

Make sure you enabled the mouse

Select mode is already enabled

Select the UI in the explorer, and make sure it’s transparency / background transparency is 0. Then try again.

Unfortunately, it still doesn’t work.

Hmmm, how old is the game? I am not sure but it could be that it didn’t get the UI Editor update.

It was created on May 4, 2020.
It was working before though.

It just shows a thin blue outline on the object and has a small square in the top left.


Is your UI in a folder, by chance?

1 Like

Nope, It’s parent is the ScreenGUI.

Can you take a screenshot of the hierarchy of your ScreenGui?


Are you unable to drag the TextLabel or the image?

I tested all types of GUI Objects, they all have the same result.

I’m not quite sure why this is exactly happening. However, have/can you try putting the UIs into a frame, restarting studio, or changing the position the manual way with properties? You can also click here, here, or here to view similar topics. Sorry I can’t be much help, however this hasn’t happened to me before.