Can't Import Custom Model Into Roblox Studio (Model Turns Invisible)

Hello, I have created my first ever model with a rig in Blender. However, when I try importing it into Roblox Studio, it goes invisible.

Rig in Blender:

Rig & Model In Roblox Studio Upon Importing Using Avatar Importer Plugin:

What I’ve tried:

  • Making my rig bigger/smaller in Blender
  • Reinstalling Roblox Studio
  • Searching for solutions on DevForum and other places

If anyone can help me that would be amazing! I’m very new to rigging and would love to be able to fix this soon so I can start to learn how to animate via Blender and import those anims into Roblox Studio or vice versa.

1 Like

Ok, I’m also new to custom models/characters, and I’m not sure why it is invisible. But, how are you importing it in? What type of file is the mesh? FBX? OBJ? Also, through the Home tab, click this:

Ok, so then I uploaded my own character as an FBX file that is already rigged, not sure how you rigged yours. I auto-rig mine through Mixamo. But, it should appear something like the following, and I want you to click this button.

which should show you what the rig looks like:
Yet, your model should appear there, and you should be able to see and visualize what the rig looks like before even importing the character.

Ensure this is set to custom:

Also, import it as a model, unless you aim to do something else.

Can you also send how and what method you use to upload your custom character? Also, through using this method, does your character appear? If they don’t, it must be a problem related to Blender. Maybe, the mesh is inside out. But, if it does appear, and then it disappears once it is placed in the workplace then I suggest you try uploading any other 3D model and drag any mesh from the Toolbox to your Workplace and see if they vanish or not. If the problem continues, try to point out at which stage it does, and show us the way you upload your character in general so it’s easier to identify the problem. Thank you, and I hope this helps! Good luck!

Edit: I don’t suggest uploading your character through a plugin but through Roblox directly, and you can watch YouTube tutorials on how to create a HumanoidRootPart, so you can animate the character in the game.

1 Like

Yeah I haven’t been able to view or see my model when importing it even using the built-in 3D importer in Studios (which I’ve never used before tbf) so not sure what’s going on. Likely something to do with the rig though I’d imagine? It let’s me import the model without the rig but not with it.

Here’s the screenshots btw →
Screenshot 2024-05-25 223058

1 Like

Can you show me the error in FileGeometry, does it say anything? I thought it might be an issue with the number of triangles your meshes have (Roblox accepts a maximum of 10,000) but, usually they should’ve given you this warning:

But, since you did not. I’m not sure why. How did you export it tho? Like in Blender 4.0 there are these options:

So, I want you to reupload it again, and find out what the issue is (which section):

It’s going to tell you which one I assume, and I think that might explain why it’s not appearing. Please send a screenshot though, so we know at least which section to target. I’m assuming that the rig is not the issue, but the geometry itself is.

Thank you!

1 Like

I uploaded it via FBX and here’s the screenshot of the File’s Geometry (it does say there’s some kind of error but isn’t showing what part is the problem the model is roughly 5k tri’s also so not above the 10k limit as far as I’m aware)
Screenshot 2024-05-26 132916

1 Like

Alright, so regarding a File Dimension issue, where it is set to inf, I searched around the DevForum, and found 2 posts you can follow:

Post 1 w. Solution


I found this comment that shows how to generally fix it.

If his comment did not work you check the Asset Manager,
Then see if you can spot a problem with your mesh such as the following, does it say there is something wrong with your mesh itself?

This is all from this post that I saw before: (I suggest you check it out, as they had the exact same issue as yours)

Post 2 w. Solution

If it still didn’t work in your case, then try this step: (It worked in another post)

Then this person responded to the comment above saying you don’t have to delete the mesh with 0 verts.

And if none of the above worked you can try this:

This was the original post of what I got:

Anyway, let me know if you are still facing any issues, or if you found a solution to your problem.

Good luck! :happy1:

1 Like

Thank you so much for all your help! Tried the first solution and turns out that was the fix for it!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.