Change Default Animations

Yes, I know this topic has been created many, many times before. That being said, I wouldn’t be here if any of them worked for me!

I have tried the method where you do: = "rbxassetid://ID"

on the server and it did nothing.

When I fork the default Animation script, the animations only play for the local player and not anyone else.

I really don’t know what to do here. I’ve tried changing animation Id’s on both the server and client. Using the Animate scripts descendants, and the ID’s manually inside the script

edit1: The last KeyFrame is named “End”. The animations are saved as “Action”.


I think people have talked about this. They said something to do with your run and walk animations being the same. I’m not 100% sure. Are your walk and run animations the same?


Here’s how you can change animations and replace them with your own.

You can press F5 in ROBLOX Studio in any place.
Find the player character in the workspace hierarchy and copy the “Animate” script.
Stop the test simulation and paste the script wherever is most convenient for you.
Replace the animation id of any animation with your own. (Inside the script you just pasted).

Then, when a players joins, you can do the following (from a local script):

local Player = game.Players.LocalPlayer;
local Character = Player.Character or Player.CharacterAdded:Wait(); -- Wait for the character to spawn
local Humanoid = Character:WaitForChild("Humanoid");

Character:WaitForChild("Animate"):Destroy(); -- Destroy the default animations

local Tracks = Humanoid:GetPlayingAnimationTracks(); -- Get all playing animations from our character

for i, thistrack in pairs(Tracks) do -- Stop and destroy all animations that are playing

local NewAnimScript = (Your script here) -- Reference and parent the new script
NewAnimScript.Parent = Character;
NewAnimScript.Disabled = false;

What’s nice about animations is that you don’t need to control it by the filtered enabled standard. If the player changes their character’s animation locally, it will replicate to other clients.

Good luck!


Animation is run from a local script! Try doing that in a local script.

However, here’s an easier method:

  1. Play the game in studio. In workspace, select your character and expand the contents. You should see all the parts, hats, scripts, etc.
  2. Select the animate script and copy it. Stop the game.
  3. Paste the script into StarterCharacterScripts
  4. You can expand the script to find all the animations that could be changed. If you change an animation, open the script and put the ID in there too.

Yes they are both the same animation.

I forked the default animation script and changed the ID’s. The animations for some reason do not replicate to other players.

If walk and run are both the same animation, change them, make walk have a separate animation and run have a separate animation. That should fix your problem. This has happened before to others and I’m 99% sure this will work.

1 Like

Just make sure you do it from a local script :wink:


The property is .AnimationId not .AnimationID. That might be your problem.


Use HumanoidDescriptions. Afaik you can also modify their animations in studio settings too for the game.


You can go in the game in studio, go to workspace, character, then copy the Animate script from your character. Go back to studio mode then go to StarterCharacterScripts and insert that script there, then you can change animation IDs from there.


I see this post has no solution, so I’m quoting an earlier post.