Character occasionally has extremely high jump

If the behavior is happening all of a sudden in both Studio and servers without an announcement or update, it’s usually a feature flag being flipped. Using an old animation corescript like this may cause glitches with FFLag behavior.


Interesting. I’ll try fiddling with that and seeing what results I end up with.

1 Like

No, if you have it enabled, change it to “Fixed” currently that is why your character is jumping so high


Oh. I’ll try that. spaceeeeeeeeeee

1 Like

“getRigScale” huh…
idk what that means but since people are linking it to r6 games it makes me question if it has something to do with the player’s avatar scaling

1 Like

I tried that and my character wasn’t jumping high anymore! I’m not 100% sure if this is entirely fixed, but for a temporary fix this seems fine. Are there any drawbacks to this?

1 Like

Yeah, the physics stepper won’t be adaptive (runs 240hz for everything, shouldn’t be a big problem). I would just wait for a verification from a engineer that the bug is fixed.


Thank you. It’s annoying that we have to wait for a fix from an engineer. Please try spreading the word, as this is disrupting a lot of games right now.

1 Like

I may have found the root of the problem:

Roblox updated the default adaptive timestepping method fflag.
FFlags are basically settings roblox uses on launch.

1 Like

i have no clue what timestepping is but this seems to be another factor
with my r6 scaled avatar (everything but body type at 100%) and the fps unlocker it happens with nearly every other jump, and with a short avatar (all settings at minimums) im not sure it would happen at all

That’s good, again for a temporary fix, just do what bigtheangry said and switch the property of PhysicsSteppingEnabled to Fixed.

Roblox… why make seemingly useless changes only for your game to break…

FYI: The animation script likely isn’t causing it. Some games are using an animate script from before this change and the issue still occurs.

1 Like

Can you please confirm if this is still an issue?

1 Like

I can confirm this is still an issue. Been happening in our game and within Studio testing.

EDIT: restarted Studio, it seems to be fixed now!

This issue is resolved for my game! I’ve switched the PhysicsSteppingMethod property in workspace to its default value and this does not occur anymore.

This is no longer happening to me. Players who haven’t left the server since before the update can still jump high, but anyone who joins after is unable to

Can you confirm? It’s fixed in Studio already, although I didn’t restart it yet.
(This might just be because Studio updates the FFlags, so maybe my mistake for asking this?)
I’m keeping my property on Fixed just to be safe for now.

Yes this is now fixed

1 Like

If they have the FFlag enabled, people can still cheat in some games by using the ‘super jump’. So… what’s going to happen with that?
(I tested it with another player who had the FFlag on. They were shaking on my screen and could use the super jump. They sometimes lag on my screen too.)

@c_5mo The fflag was deleted. But yes, there are tons of abusive fflags that have been found. Most of the op ones have been patched. Bitdancer has said he will be pushing out a patch to possibly remove fflags editing client side, but we’ve seen no progress on that.