Connection errors such as “Connectfail” and “Could not fetch” error keep happening in studio / clients in East Asia regions

Reproduction Steps

How I fix this "connectfail" and "could not fetch" error?

https://devforum.roblox.com/t/roblox-hate-me-apparently/1849367?u=penguindoc9999
https://devforum.roblox.com/t/roblox-hate-me-apparently/1849367/2?u=penguindoc9999
https://devforum.roblox.com/t/roblox-hate-me-apparently/1849367/7?u=penguindoc9999

Alot of people living in east asia region, including me seems to be having this issue. It has been happening for several months and it is severely affecting studio / client experiences.

Direct Links : It happens in all places.

System Information : Windows 10 64Bit / 32GB / AMD Ryzen 5 5600X 6-Core Processor 3.70 GHz

Beta Features : Channel Animations / CSG Version 3 / Material Service / New Mesh Importer / Particle Flipbooks / Save Rig with Animation / Volumetric Sounds

Expected Behavior

Whenever I open the Studio it should be opened normally without any problems at all.
Whenever I join a game, I should be joined into the game server normally.

Actual Behavior

- Issues with Studio

Bug1
#It fails to login with error message saying “Failed to get moderation status. Please try to login again or try to contact support if problem persists.”


#In test mode, it sometimes fails to get my player informations & avatars.

#Some assets, such as Sounds and Decals won’t load. This is not related with the moderations.

Bug3
#It fails to open studio with the error message above.

#Skybox, Atmosphere will randomly get disabled, showing pitch black sky instead.

#Publishing / Saving a game to Roblox will take ridiculously long time, or even fail.

- Issues with Client (Roblox Player)

#CoreGuis, such as Topbar, Leaderboards, Inventory and Development consoles won’t load for 7 ~ 10 seconds as I join a game.

#It will not let me join a server, even though the server is not even full.

#It will not even show up after clicking the ‘Play’ Button.

Workaround

Trying again until it opens without any problem at all.

Issue Area: Studio / Client
Issue Type: Connectivity
Impact: Moderate
Frequency: Often
Date First Experienced: 2022-05-25 00:05:00 (+09:00)
Date Last Experienced: 2022-06-29 00:06:00 (+09:00)
A private message is associated with this bug report

6 Likes

Again as posted on the ‘previous’ thread, I’ve DMed Bug Support about this, and the agent that answered me was very vague with the answer and linking seemingly vaguely related DevForum posts/bug reports.

One thing that I am pretty confident about is that it’s possibly an ISP (networking/privacy protocol) issue unrelated to ROBLOX. However, if that actually turns out not to be the case, then this needs to be immediately investigated, instead of just giving us vague answers.

1 Like

Bump.

I’d like to say that after the latest Studio/Client update, this does not seem to happen as often anymore, as to majorly disrupt my workflow. Still pops up once in a while, but otherwise this could’ve been alleviated silently by a ROBLOX engineer that decided not to reply.

4 Likes

This is still happening to me, not sure why. It’s not as bad as how OP describes it but ocassionally I will get that “moderation status” error and I will often get the connect fail error. My roblox also consistently breaks almost every other time I join a game.

I straight up can’t use anything but the DevForum. :slightly_smiling_face:

I’m skeptical if this is due to MY network or Roblox’s, but about an hour and a half ago Roblox just stopped working for me entirely.

Studio gives the same Failed to load settings error as this original post, and every single backend API fails in Chrome’s Dev Console.

This is nearly frustrating me to a point that cannot be expressed without an outburst of violent physical contact between my fist and an object I have yet to choose around my room.
Oh and this stops if I use a VPN, Roblox also momentarily comes back if I swap my static IP. So I’m at a loss. If this is unrelated to the OP, I’m sorry. But that studio popup is the closest thing on any topic I have found these long 90 minutes.
STOP GIVING ME HOPE


I don’t know if these are helpful screenshots, I’m just posting out of desperation at this point.
And I still don’t even know if this may be an issue with my own network!

I’ve been having the same issues all day.

I’ve also been having the same issue all day.

For the mods that come across this:
image

Also should be noted that none of the icons for any of my games are loaded:

Are all of you also located in East Asian countries like Japan or South Korea? I believe this issue for East Asians are solved as I am no longer experiencing this myself, though it could’ve popped up again elsewhere in the world.

This is really frustrating, I have better than average internet yet I can’t connect to a game.

My Laptop Specs

Dell G3 15 3500

OS: Windows 10 Pro
image

GPUs:

  • NVIDIA GeForce GTX 1650
  • Intel(R) UHD Graphics
1 Like

Hey folks, the first poster marked this post as solved in a reply above.

Could you file a new bug report that follows the bug report template and has all relevant information (logs and such) attached? Our team will take a look at your specific cases then.

Locking this thread for now since this is resolved for the poster!

1 Like