Constantly Disconnect From Game

Reproduction Steps

go into any game on Roblox from Asia region that also has a teleport feature

it seems like the client and server couldn’t establish a connection

Expected Behavior

to not disconnect and successfully teleport

Actual Behavior

i disconnect 8/10 times constantly when joining the game and teleporting

image

Issue Area: Roblox Website
Page URL: [NEW CODE+RELEASE ⚔️] Attack on Titan: Evolution - Roblox
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-08-05 00:08:00 (+07:00)
Date Last Experienced: 2022-08-07 00:08:00 (+07:00)


Possibly Related

6 Likes

Also, possibly related (router problems):

1 Like

I’ve been getting this issue for the past few days too. Though I am in Southeast US and am getting it when first joining my experience rather than teleporting. I was able to get into my game through play mode in studio, but joining through the website seems to always give me error 277.

Edit: I have tried connecting through a different internet connection (Mobile Hotspot) and still get the error same as before. I can get into most games, but not this one: Testing2 - Roblox
I’ve also tried a few different computers all with the same outcome.

4 Likes

It’s likely related to this issue: Player randomly being disconnected from server but still replicating to other clients - #18 by TheLegendaryEggMan

Despite the inactivity in the thread, the issue is still very much ongoing, affecting us daily.

2 Likes

This is in the wrong subcategory.


I have seen this issue multiple times, but when using an ethernet port the issue decreases. However, sometimes Roblox does this when my internet is perfectly fine. I rejoin the server, and everyone is still there. That’s odd.

1 Like

This issue doesn’t seem to be occurring for me anymore. I was able to get into my place like normal yesterday and today.

3 Likes

Thanks for the report. Do you still encounter this issue ?

This bug did end up reappearing for me after not occurring for 1-2 weeks after my above post where I said it was no longer happening.

I was able to fix it this time though, by disabling a script in my game that loads in some large models from InsertService after the server starts. In my case it is about 7 different large models that are brought in to the workspace by InsertService:LoadAsset(). I do have a live game which also has the same behavior and loads in the exact same models which has never had this issue, but it is currently a much smaller place so I believe it has to do with the very large size of my current place + the additional loading.

4 Likes