Constantly getting disconnected from Team Create

In the past day, there has been a significant amount of downtime while using Team Create.

Today I have been disconnected more than five times.

Some other developers have told me that they have been experiencing constant disconnecting as well, beginning earlier last night.

This seems to happen regardless of operating system, but I’m running macOS 10.15.3 on the latest build of Studio (0.419.0.381237)

11 Likes

Happening for me as well, every hour or so.

Windows 10

Oddly enough - only 1 of the 3 places I have open keeps disconnecting. The other 2 haven’t disconnected all day.

Started happening last night although I thought that might just be Wednesday updates happening.

Just began noticing that Team Create is not recognizing or saving any edits I make to scripts. When typing in a script, it doesn’t show the * next to the script name, and using play solo uses old versions of the script. When I close a script, the changes are reverted.

This is the error I got, has only come up once in this session.
image

I just got disconnected again and snapped this error:

Can you provide

so we can check backend logs? We have the time/error message from the client, so mostly just need placeIds now.

1 Like

I’ve been working on Team Create only in this place; 560612018

2727072708

Post must be at least 30 characters

Studio is failing to save to Roblox when I want to turn off TC. Produces this error:
Screen Shot 2020-02-13 at 2.13.18 PM

Our scripts are being reverted when team create disconnects, and this is happening every 15-30 minutes. It’s made it impossible to develop for the time being :frowning:

One of the other places started having this issue as well (2801784955) so our builder is being frequently interrupted now too, and he says his building changes are being reverted (within 1 minute of disconnect)

1 Like

Could you provide Studio log file for session suffering from disconnect?

It was a problem for like 30 minutes - but seems like it has solved itself now.

Edit: Just kidding - I cannot save any scripts.

Edit 2: A log attached when I disconnected

disconnect_log.txt (21.4 KB)

We’re still being disconnected, so this issue is not solved.

Will upload a log file! (Give me a few minutes for it to happen again)

Can’t save places and publish packages too.

Here’s my logfile.

Note: when I disconnect, so do other team members at the same time.
(Logfile also mentions Client has been disconnected with reason: Roblox has shut down this game server for maintenance)

log_A18ED_1.txt (19.0 KB)

My teamcreate is disconnecting still, last happened around 3:50 mst
The place it happened at was here: https://www.roblox.com/games/1584363130/NOTORIETY-PT?refPageId=19d5dd8d-521f-4bcd-892e-9b42c80bdbd3
My userId is 5283599.
I got this error right before the disconnect, and other team members were disconnected at the same time.
unknown
Here is the logfile I believe was associated with the disconnect:
log_BB6F1_1.txt (16.1 KB)

Seems its site-wide issue. Some webpages don’t work too.

It looks like there is a backend service outage at the moment that is affecting us platform-wide. You may encounter other issues like failing to log in or open published places in Studio. Our engineers are working on rectifying this ASAP.

3 Likes

Server issues maybe, this isn’t the first time this has happened. Don’t worry, it will get fixed soon! :heart:

1 Like

To clarify @Usering @AbstractAlex @Brick_man, when this happens, you do get a Team Create disconnection prompt that allows you to download a local copy of the place, correct? Or does the Team Create session allow you to keep editing and continually logging save failures to the output?

Not counting losing script changes (this should be solved with new Drafts feature), is there anything we can do that would improve the failure handling when the backend fails? E.g. make it more obvious there is a failure, etc

1 Like

Team create properly disconnects and displays the prompt to close studio, reconnect or open the local copy. Only had the issue with scripts not saving but staying in TC one time. As of right now I have disabled Team Create since I need to get work done.