Constantly getting disconnected from Team Create

Reproduction Steps
I don’t know how you can simulate the same situation, as it may be a localized problem, however, there are other topics similar to this one already reported in this forum, like this one:

Expected Behavior
There could be no such disconnects after Team Create is activated.

Actual Behavior
I started using Team Create just a few days ago, but since then I’ve been getting these error messages constantly:


It is important to point out that these disconnections occur in different ways: sometimes I can work 1 hour without disconnection. Disconnections often occur constantly.
Apparently, it’s instability on the Roblox servers.

Issue Area: Studio
Issue Type: Crashing
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-12-19 00:12:00 (-03:00)
A private message is associated with this bug report


The same thing is happening to me, isn’t it an issue with my device or internet as I tried it on my Macbook and my Computer as well as resetting my router, using my phones 5G And when visiting some family I had the same issue on there internet as well.


Hi, thanks for reporting this. Is the issue persisting?


Less than before, but it still happens. In the same way as error 277, that is, it happens in certain periods.
As I said before, I can spend for example 1 hour using the game without the 277 error or the Team Create connection error and then everything becomes a nightmare, I can’t test my game or keep two Studio instances working on editing the same game without errors.
I’ve already tested several things on my Windows 10, my router, my internet, but it didn’t change the scenario.
My internet is stable, 100 Mbps full-duplex optical fiber, everything works fine except Roblox.
If it’s a clue, on the same computer, my kids eventually play a few Roblox games without a hitch (eventually some error 277).
But in my case, the constant error is almost a rule!
It’s highly disheartening, frustrating.
Mainly for my project, where I’ve been working for over 1 year and now that I need to test on multiple servers, this has been a nightmare!
It appears that there are some Roblox servers that are more stable than others and that, apparently, some more famous games use these more stable servers and others that are simpler (or that have not yet been released, as in my case), just keep the weaker servers.
Am I right?

Hi @rogeriodec_games could you send another screenshot of the error message so I can get a more recent incident ID?

BTW how are you connecting 2 studio instances to the same Team Create project on the same machine? This is indeed possible but it is not strictly speaking something we support in Roblox Studio, Having said that I don’t think it’s what’s causing your connection issues.

I don’t believe we give any games special treatment in terms of “more stable servers”. Sorry that you are experiencing issues!


I’m using a virtual machine (another Windows 10 in VMware).

But so far, absolutely NO ONE can tell me what is REALLY causing these 277 errors. There is no measurement tool, no diagnostics, just a ungrateful generic popup indicating error 277… and you should know more than I do that there are THOUSANDS of similar complaints…
How am I going to be able to make my game work with such instability? Could someone follow my case more closely?

1 Like

6 posts were split to a new topic: Off-topic responses on “Constantly getting disconnected from Team Create”

In fact, what I BEG the most is for a stable environment where I can work without having to restart my game and redo every step TENS times a day due to these constant disconnects.
I’m debugging the game, I need to keep my attention, focus, concentration. And every time these disconnects occur, I lose everything, I have to go back to the whole original point.
These are HOURS of work lost just because of these problems.
Many people would have given up already…
Developing on Roblox is not for the faint-hearted…

Sorry again for your issues rogeriodec_games. I dug a little deeper into the incident you reported and unfortunately am not able to find any specific information. We are working on adding better error logging for investigation issues such as yours but this will take some time. From the error message in the log your shared, it does seem to be the case that the server was shutdown or crashed for some reason causing you to disconnect. Does this happen on ALL your projects or just one specific project? If it’s only one specific environment, can you DM me the place id? Since this appears to be a team create project, are there other devs working on your project and do they also get disconnected? If there are not others working on your project, have you considered disabling team create as a temporary solution?

Again, we strive to provide stable environments for ALL our devs, whether they are one of our top devs or someone completely new to the platform. I believe it is the case that servers are divided by regions though and there may be some region specific instabilities. We constantly make improvements to our servers so it’s entirely possible that your issue will just go away soon.

1 Like

@JamJooJoo @theworldis_socruel @TheEldritchDreamer

Your errors are not the same as in the first post here. You should file your own bug reports instead of tagging onto this one. Not every error message / issue where Studio can’t connect should go on the same bug report.


0.509.0.5090219_20220114T114704Z_Studio_BDCD6_last.log (38.6 KB)
0.509.0.5090219_20220114T112502Z_Studio_2A39E_last.log (48.1 KB)


This is just the first warning for today.
After this one, I’m being disconnected every 5 minutes or less…
And I’m using only 1 Studio instance for now…

I had to turn off Team Create to be able to work today…
What’s going on?

I ran into this as well recently, if I leave the debugger sitting in a breakpoint with TC active for a few minutes, it disconnects.


@rogeriodec_games - is this happening when you’re sitting in a breakpoint or when you’re simply play testing?

33 posts were merged into an existing topic: Off-topic responses on “Constantly getting disconnected from Team Create”

This bug report is NOT for the on-going incident on January 19.

Stop using this thread for unrelated issues. File a new bug report for new issues.


I mainly have this issue when I make the game public or private. Sometimes I don’t get disconnected, but when changing privacy, I usually do get disconnected. (This happens 90% of the time)

This happens almost always when I’m not doing anything on one side. No breakpoints, just the error suddenly appears:

Again, I’m using Windows 10 and another virtual machine (VMware) with the same Windows 10, as I often need to debug the script that is running by a secondary user, and just for that, I use the virtual machine.
It would be so nice if Roblox created diagnostic tools…


While I was writing this post I get another disconnection:
Incident ID: 5583729114904660917
Place ID: 7206635220

First of all, I want to offer my sincere apologies to the Roblox team regarding this topic.

Error 277 (also, the connection loss issue in Team Create, the source of this topic) has been with me for years and there has never been a satisfactory explanation (except the more standard explanation which is: problems with my internet connection).

Roblox Player error 277 occurred both on my Windows 10, connected via cable with my router (100 Mbps connection, optical fiber), and on my Android, via WiFi.

But a few days ago, I decided to do a simple test: run Roblox Player on my mobile, using ANOTHER INTERNET CONNECTION, in my case, my 4G connection from my phone operator.
And guess what? NO ERROR 277!

So the problem wasn’t really with Roblox but with my connection.
So, I replaced my router (the same one I’ve been using for several years) with a new one.
And guess what? NO ERROR 277 (nor lost connection to Team Create) anymore!!!

In short:

All the errors reported in this topic were only related to my router failures.

The only curiosity is that everything has always worked fine on this router, except Roblox! So there’s something very sensitive in the form of the connection used by Roblox, which I can’t explain.

Anyway, the problem is solved.
And may this also serves as a support for future users who experience the same problem.


This topic was automatically closed after 12 hours. New replies are no longer allowed.