Dark Bubble Chat Scripting

Here’s a place with everything set up
Dark Chat Test.rbxl (126.7 KB)
Try it out :slight_smile:


i cant chat in it in studio

Could you post a video? I’m pretty sure I made a script to enable all the chat features

Try chatting ingame. I normally have issues with chatting in studio and I get it to work by chatting in a live server.

1 Like

If it is in studio, this is an ongoing bug that is been happening to me as well.

Look at this, for example. Furthermore, I’d recommend testing it out in game for 100% success rate in showing up.

The only solution for it to work completely in studio is to Disable Accurate Play Solo, which I highly go against (and won’t even be an option in the near future).


Ok to do this first you need to copy all chat files. You can do this by Clicking Play and Copying every file from Chat.
slika slika
Then click Stop and paste all that files into Chat. Now go into BubbleChat script and do this:

  1. After line 198. paste this chatBubbleMain.ImageColor3 = Color3.fromRGB(0,0,0)
  2. After line 211. paste this chatBubbleTail.ImageColor3 = Color3.fromRGB(0,0,0)
    (this will make background black)
  3. After line 425. paste this bubbleText.TextColor3 = Color3.new(1,1,1)
    (this will make text white)

Hope this helps! :slight_smile:
Also in studio chat sometimes doesnt load, but it will work in game.


No bubble chat in the game when you type something.

If you are having issues editing the chat script, just use the place file I uploaded and publish it to roblox. Play the game from the website, not studio.

I tried, no chat too

Is bubblechat enabled for your game? Or is chat generally broken for your game?

There seems to be an issue with the current chat api

Please try this game and check if the chat works for you

Game is now closed due to privacy reasons.

There’s a post regarding this issue

Can confirm that it works on the place above. :+1:

@XxKinqSinisterxX Can you show visual images to show what is wrong with your chat?

Here’s a place with forced-enabled chat features

Dark Chat Bubbles Fixed.rbxl (126.6 KB)

(The chat should be working now)

1 Like

You need to enable BubbleChat, you can do that by going into ClientChatModules, ChatSettings and changing lines 26 and 27 from:
module.BubbleChatEnabled = PlayersService.BubbleChat
module.ClassicChatEnabled = PlayersService.ClassicChat
module.BubbleChatEnabled = true
module.ClassicChatEnabled = true
that will force enable both bubble and classic chat which should fix your problem.
Also you can publish the place and in place settings activate both chats (or just bubble) but im not sure if that will make it visible in studio.

1 Like

There is an ongoing issue with studio chats. It’s best to test the chat in a running game.



Where is that?

I see, it is still white though I did everything.

Sorry for going off-topic a little here, but I feel that I have to make an obligatory reminder in the off chance that you’re getting distracted from finding a solution to the OP: when you’re forking the Chat scripts (which means doing the whole Play -> Copy Scripts -> Stop -> Paste in Studio), you do not have to fork every single chat script, only the ones you need to edit.

In the case of bubble chatting, there is a specific LocalScript that is meant to handle bubble chats. You only need to copy that script back after fetching it from a Play Solo session. The other scripts are automatically inserted at runtime if equivalents do not exist already.

1 Like