Developer Hub API Reference Down

Oi guys, the Developer Hub API Reference is down and points to a 502 Bad Gateway.

https://developer.roblox.com/api-reference/class/Frame

Anyone else experiencing this?

8 Likes

I can confirm i’m, experiencing this issue as well.

1 Like

It’s working for me

Is it working 100% of the time? If so it could be a DNS issue on my end. Though since I’m not the only one it could also be on Roblox’s end.

Can confirm as well, I am having the exactly same issue.

1 Like

Possibly related to Cloudflare going down?

Yes, that’s most likely the issue

Thanks for reporting the issue everyone! We are going to keep this on our radar just to make sure the site is performing as expected.

2 Likes

Currently down for me. Many redirects that keep adding /false into the URL. Just started this morning, was working last night.

https://developer.roblox.com/api-reference

now results several iterative redirects that culminate to:

https://developer.roblox.com/false/false/false/false/false/false/false/false/false/false/false/false/false/false/false/false/api-reference

which fails to resolve.

Works perfectly fine for me. You sure the error isn’t at your side?

Fails in this way from two different devices on two different ISPs. Desktop on land line, and phone on cellular data only (disconnected from wifi).

Ontario, Canada

Im getting the same error, each time I try to access it I get the /false/false/false… which doesnt let me access the page; due to too many redirects

Alternate (archived) access can be found through Waybackmachine.org:
http://web.archive.org/web/20190428193748/https://developer.roblox.com/api-reference

developer.roblox.com is still down for me, doing the redirect /false thing

I’m getting this false redirect thing as well. Upon loading the any part of the site I get a too many redirects error. One of my links for example: https://developer.roblox.com/false/false/false/false/false/false/false/false/false/false/false/false/false/false/false. I’ve tested this on my phone in addition to my iPad, each yielding identical results.

So I’ve tested to see if it worked with other browsers (I use chrome) , and I found out that I can enter developer.roblox.com with edge. And i’ve tried doing everything; but still cant enter the page with chrome

Also did that, except it works on Chrome:

Update: the site is only failing on Safari for me, mobile and desktop Safari.

1 Like

Can relate, it is failing on safari, but on Chrome it is working, for my friend it even doesn’t work on Chrome.

I have been trying to look in API reference too.
This is the second time that it goes down. I already cleared cache and even tried from a different device.

It has been down for over 5 hours, showing a variety of errors, from custom 404 screens to bad gateways, etc.

It is also worth noting that not the whole website is down, only certain paths.



3 Likes

Also able to confirm. Valid pages like Workspace now throw 404’s for no reason: Seemingly for some reason almost anything within the /api-reference/class scope no longer exists.

2 Likes