EZLaptop | the REQUIRED plugin for ALL laptop developers!

Hello, thank you for looking at my post. I recently made a new plugin that lets you rotate your Roblox studio camera using your arrow keys. This really helps when you don’t have a mouse since the only way to rotate your camera is right clicking.

I personally am using a laptop and the trackpad fails a lot so I’m using the plugin instead. I have it saved locally so it only affects my laptop and not my pc. Here is the plugin:

Screenshot 2022-12-27 022810

CONTROLS:

← Left
→ Right
^ Up
down

38 Likes

I rarely use my laptop for development anymore since I got a computer but I know that this would have been a game changer for me back then. I can see this being super useful.

1 Like

Thanks for it! My mouse sometimes breaks for a while and trackpad isn’t a solution, Will be using this in some point :wink:

2 Likes

Definitely seems useful. Trackpads are super annoying to use and I can see this as a great alternative. Good plugin

2 Likes

This plug-in has completely ruined my studio movements. I tried re-installing it but even uninstalled, I can’t move. I don’t know if this is the plug-in’s fault or anything that has to do with studio, but it has completely ruined my mouse control. I cannot move nor rotate with the mouse.

This is not to be seen as hate, I am just very confused…

clickbait title laptops can have mouses

keybinds are cool though and i wish everything could be done easier with them…

3 Likes

Same here. I had to disable the plugin (make sure to disable it before uninstalling it, sometimes when you uninstall plugins that change studio controls or core stuff without disabling them first in the Plugin Manager window their effects can still be seen even after uninstalling) for it to go back to normal

Gosh darn it, you should’ve released this BEFORE I returned my gaming laptop!

Kind of broken but Thank you for this

If you’ve fixed it, could you explain as to how you did it. I had it disabled and then decided to uninstall it but it doesn’t budge…

Update: I have fixed it, still thank you @1DiamondBor

The old version of the plugin set the camera to scriptable which breaks mouse movement. Once I figured out it was disabling people’s mouses, I redid the code. The newest version should give a popup in the top left corner of your screen to unlock the camera if it detects that your studio has been affected by the old plugins bug.

You can also do it manually by going to the camera object in workspace and settings its cameratype to custom
image

1 Like

The reupdated the code and it should work on all devices. Roblox has a dumb feature where you have to press update because they wanted to seem like the app store. The old version disabled the mouse as it had one line of code changing the workspace camera to scriptable which would completely disable your mouse movement controls. I fixed this in the future updates and I even made a popup that detects if your camera is stuck which prompts you to unlock it. I tested it with a mouse with the new plugin and it seemed to work good but maybe there is still something else?

If you are still having issues with the plugin, contact me Black Ben#0652

1 Like

Thank you! I really do want to apologize if my comments sounded harsh in any way ( not intended )
Just play-tested the plug-in again,works like a charm!

It’s okay because I would be pretty annoyed if a plugin I just installed broke my roblox studio

2 Likes

Looks great! Recently, my mouse has stopped working so this feature is great for quality-of-life.

1 Like

Woulda been helpful if I had this when developing away from home… :sob:

2 Likes

Thanks, I appreciate you making this resource publicly available, as I’ve lost my mouse recently and won’t have it till later today. Is there a sensitivity setting? If not it would be nice to have a NumberValue of sorts which we could change.

There is not a sensitivty setting however if you edit the soruce code it should be very easy to do.