"Failed to update price" error when trying to take a group plugin off sale

If you upload a plugin to a group, when trying to change the sales status (whether it is for sale or not), you see the error “failed to update price”. I have verified this is the case with two different groups, one in which I am the owner, and another where I am in a role where I have permission to edit group assets and sales.

I cannot edit the sales of either of these plugins:

However, I did find that I can edit the sales of plugins that I upload to my profile, not to a group.
I can edit the sales of this plugin, which is published to my account:

Here is a gif of the error popping up (it happens every single time, so reproduction should be very simple): https://gyazo.com/615744351039c6c77251c85e5d98cafe

[Edit]: Okay, 2 years later and this issue is STILL a thing and has not even been ACKNOWLEDGED. For the peabrains at Roblox who can’t fix fundamental issues like this, here’s what the issue looks like in present day:
(This is a plugin under my group, that I have edit permissions for, but apparently I “don’t own this asset” and can’t take it off-sale. I can do everything BUT take it off-sale.)


Having exactly the same issue with my group plugins still (Feb 2021, 3 months later). The plugins in question are not meant to be public, and people are downloading them, and I have no way of stopping it.

Plugins I cannot edit:

Getting the exact same error as Fluffmiceter demonstrates in their GIF.


The same is happening to me. I can control personal plugins but not group plugins where I’m the owner of the group and the person who published the plugin.

1 Like

This same issue is occurring to me where it says failed to update when setting my plug-in not for sale to true.

This issue is making it impossible to set my item for sale off.

So I noticed that everything else updates when trying on the plugin, such as setting the genre or open for comments.

It’s just the setting the price part that doesn’t update for me still.


Bumping because this issue is still occurring.

A temporary solution would be making the Plugin disable itself under certain conditions.

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


Same thing happening to me…I tried taking it off sale

Just now having this problem. No solutions?

Still happening to me. I accidentally uploaded a plugin to my group and I don’t even see the sales tab.

More details here.

Sorry for the bump but the issue is still happening. Even with the new Creator Dashboard, I can’t take my group plugin off sale or edit the price.

It states that “You do not own this asset. Distribute on Creator Marketplace could not be saved. Please try again.” even though I am the owner of the group.

1 Like

This is still an issue. I’m also unable to install my own group plugin without paying for it first.

This is STILL an issue. WHAT IS GOING ON ROBLOX? I’m getting so frustrated by this blatant problem that has not even been acknowledged. In my group, I have a development tool that is supposed to be private. But, because I made it on-sale once to share it with a coworker, now it’s been public for the last three years. Seriously Roblox. THIS IS CRITICAL

Hey everyone!

We are looking into the issue and will update you as soon as we have more information!

Thank you!


Hi @Fluffmiceter,

This issue should be fixed now. Thanks for your patience and please let me know if you encounter any further issues with this bug!

Thank you!


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.