Game crashing when attempting to join

I am getting reports of game crashing when players attempt to join the game, I personally could not reproduce it for my own account, however, after working with someone that reported this, we’ve found this in the output on the server:

image

When they join they get stuck on this screen:

When attempting to close out, the game crashes:
image

It appears that the game DOES load a little bit as they can hear the Lobby sounds, though when trying to leave that sound stays playing for a bit after the window has been closed

I’m unsure of when this started happening (if it’s after the latest Roblox update or not)

This is the game in question: 4589846137

12 Likes

Can you reproduce this for any other game (from a different developer)? If not, then it may be game-specific, and could possibly be the result of a backdoor.

1 Like

I can’t reproduce it myself, it seems to be happening to random players…

I’ve done all that I can possibly do to rule out anything that can be on my end, however since they are crashing on that screen AND that error line showing in the output (Which I’ve never seen before) I’ve filed this report.

The players in question said this is game specific as it is not happening to them for other games.

I am 100% sure this is NOT a backdoor.

Thanks for your concern though!

4 Likes

Hello! The game in question is currently inaccessible. Can you please confirm that the issue still occurs? Thank you!

2 Likes

I’ve also been experiencing this “Security timeout” issue on one of my games. At very random intervals (sometimes after 20-30 minutes of playing), one or two of our players will randomly have their clients freeze to the point where they need to quit ROBLOX and rejoin. At the same time, some players report their game crashing as soon as attempting to join, similar to what OP described. On the server-side, the console says “Security timeout” along with a user id, which matches the id of the players reporting frozen clients.

Our game is public and accessible here (3664995855). We have received user reports about this issue since 1/20/2021. I have run a full search in explorer for Scripts, LocalScripts, viruses, etc., as well as malicious plugins, and am certain it is not a virus/backdoor issue as some people have suggested.

8 Likes

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

4 Likes

Hello!

We’ve put the game under restricted access to the QA Role of the holder group so to prevent the dislike/like ratio from going down before release.

We’ve only started experiencing this recently, we did not have this issue during tests in December.

To make extra sure this is not something from our end we’ve opted to refactor any code that could possibly cause the client to crash.

Hope we can figure this out soon :sweat_smile: the game is literally ready and we’ve had to hold releasing till a solution is found.

1 Like

This is also happening to me but it happens to me in all games, but the game does not load it just opens the error box.

I had this occurring in a group game our team has been working on. On a new server, the first player that joins is fine but any players who join afterwards get the frozen loading screen. I traced it back to a local script that handles our UI - and ironically after making a typo for a debug remote event, the problem was solved (of course the UI script couldn’t remain that way). So I yielded with a reasonable wait time (3 seconds) before executing the rest of the script and it worked fine.

I’m not sure why exactly this happens; debugging the script, it doesn’t get past grabbing the Roblox services I use (Replicated Storage, Players, StarterGui) but it causing an error (or yielding) beforehand stops the timeout.

If you can isolate a certain script that is responsible - even with no potential infinite loops - you may be able to patch it with this method. To check where the local script executed I used a remote event to grab debug info since the client dev console isn’t available from the frozen loading screen.

This is happening to our game (6707475252) as well. I am bumping this because there has been no real solutions or response from developer relations. It’s causing our game to lose players and I (as well as the rest of the scripters in our development team) are unable to understand what is happening. Like vikingboy, I’ve done a throughout search for backdoors and hidden scripts.

Mention: Our game uses a lobby with many other places underneath it with TeleportService. I am unsure if this impacts anything.

Update: After searching through the logs, I found a script timeout error that was probably causing the issue. If this is happening to you, go to %localappdata%/Roblox/logs as the bug report’s pinned post suggest and read the log. You may find the issue there.

Necro bumping this to say I am getting this for a game I’m working on. Cannot find any useful information related. Blue text in the console that reads "Security Timeout for userid "

I also am getting this for a game I’m working on. I also cannot find any useful information related for solutions etc. Same blue text in the console that reads "Security Timeout for userid ". Happens seemingly randomly for random players in every server of the game a couple times per hour or so. Can we get any help on this from devrelations?

1 Like

Today’s update caused my project to disconnect the client upon game start with error message “The current identity (9) cannot Class security check (lacking permission 6)”.

The way around it was logging out of studio and logging back in. Maybe in studio, logging out…logging in and publishing the game will help solve this.

Exact same issue here. (also very happy it isn’t just me experiencing it! :slight_smile: )

When a player disconnects, the server log gives out this message…
image

I’ve also experienced this myself, I think (just assuming) when this happens your client stops sending data to the server . You’re able still see what is going on in the server until you eventually get kicked from the server.

No idea how to reproduce this disconnect tho. It’s almost like it happens at random

2 Likes