Granting audio access to game doesn't work

I’m irritated and confused.

Apparently, you need to have edit access to a Universe in order to play audio in them. Is that correct?

Does this mean full Studio permissions? I planned on playing audio that I uploaded in a game made by my friends, but it wouldn’t be appropriate to ask for edit permissions just to do so. I don’t want to edit their game, I just want to play audio. I don’t understand why this is the case, so if this could be elaborated further, I would appreciate it.

Does this also mean I can’t even play recently uploaded audio that’s under 6 seconds in places either? I don’t seem to recall this being mentioned in the Audio Privacy Update thread at all, and if it has then I must’ve overlooked it.

This annoys me, because I don’t see why 6 second audio should be treated as if they’re music tracks. It would be enough for a short SFX, but definitely not for an entire song. This doesn’t need to be difficult, but it is.

I’m also paying 10 ROBUX for audio that I can’t even use outside of my own games. Now, to many that might be considered pocket change, but I would probably get more out of buying an accessory for that much right now. That’s how upsetting this is.

If it’s this complicated, then I can’t see how people are using the Sharing setting. I’m concerned that the ability to once again distribute audio assets in the Library is going to take a fearful amount of time. This should be treated as a priority, not just another thing on the to-do list.

The proposed solution better not be by “verify-gating” the feature either, because that would be really cruel.

I’m not trying to ask for much here, but I at least want some transparency on this because I want to be able to do more with audio just like I could several months ago, even if it’s not as much.


I have no clue if its the intention, however I believe you need edit access to prevent bypassed audios. I know in the game HCBB 9v9, there was an incident where someone had a bypassed audio of someone saying a racial slur and it got a streamer banned permanently from twitch.

I believe there should be a setting under privacy for games that should have a toggle of whether or not they allow all audios or only audios with granted permissions to be played in-game.


I did not realize this topic was still up, so I will clarify with this post.

I was wrong. I’ll quote myself from another topic so I don’t have to rewrite it.

There is no way to mass bulk grant a universe’s audio permissions without capping the amount that gets authorized per grant. Granting audio from studio is simply impossible to do, and to “publish as” any universe will cap all audio sounds’ permissions.

I do not have the ability to post a bug report about this, so I am posting the issue here for where it is relevant.


This situation really adds insult to injury, Roblox has managed to make the audio update even worse on release than on paper.

1 Like

I cannot even release the audio to the marketplace! Why is that?

1 Like

The Granting Audio from Studio feature is now gone. Everything has to be done manually through the site.

1 Like

this is still not fixed;
I add an experience to an audio, I save, I reload the page and the experience is gone from the allowed experience list…


it just seems i am unable to give access to experience that i don’t have access which is dumb…
i need studio access in order to share audios with friends games?..

1 Like

You pretty much need edit permissons to “experiences” basically because otherwise you can’t apply the audio permissions to that game otherwise, this was most likely done to prevent people from giving audio access to a experience that they made so they could bypass the private audio thing and play their music with boomboxes and as such in games.

1 Like

The easiest way to do this is by inserting audio you own from the toolbox into the experience you’re editing. I am very sorry if this does not work for you but it has been working for me the past few times. But if you copy and paste a private audio asset the system can’t verify that you are the person who uploaded it so you have to either reinsert that asset from the toolbox or grant permission through the configure page.

1 Like

I’m still having this issue, just wasted 3 hours of my time granting 200-300+ sounds just for not a single one to actually apply, was a fix EVER applied for this?


I’m still affected by this issue. I am attempting to use sounds that are uploaded to a group I own and I am getting the following error in the output:

Failed to load sound rbxassetid://14826355208: Unable to download sound data.

This is currently affecting all audio uploaded to my group that are being used in a group experience.