Guide on how to fix script editor lag (macos)

So I’ve been using my MacBook pro for a while now.
For me, the script editor became really unresponsive and had a huge delay between typing lines.

After completely factory resetting my MacBook and trying various different techniques I finally found what is causing this issue and how you can fix it.

The problem lies with the display settings of your MacBook, Roblox Studio doesn’t like the Colour LCD profile or any other profile that is not natively RGB.

to fix this go to [System Preferences] > [Displays] > [“Color”] and untick “Show profiles for this display only”.
Now scroll down until you find “LU28R55” or “sRGB IEC61966-2.1” Select it and restart your Mac.
If it is still lagging it could be that you have to reinstall Roblox studio.

Hope this fix will be useful for those who have this issue.


For some reason, clearing the plist files and re-installing Studio directly after also resolves the overall MacOS lag while using Studio.

1 Like

I have tried that method but it didn’t fix it for me.
the way I figured it out that I had to change my display colors was because @Evanbear1 tried Roblox studio on his mac mini that was plugged into his monitor.
So I plugged my MacBook into my monitor and found out that that got rid of the lag,
so I went and checked the display settings and I saw that the display settings that my monitor was using “LU28R55” and My mac "colour LCD "changing it to the same profile and restarting my mac fixed it completely

Reinstalling studio does not work, and from experience changing color profile only has ~50% success rate. The failsafe solution is creating a new user profile on your max, if this does not work then it’s your hardware at fault.

1 Like

Thank you so much. This lag really held me back for far too long, nice to see I am able to be in Studio again.

1 Like